Unable to update from 14.0.1 to 14.0.3

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 14.0.1
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4
PHP version (eg, 7.1): Php 7.2

The issue you are facing:

Updater shows an error saying

Check for expected files
The following extra files have been found:


Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Login to Nextcloud
  2. Go to admin settings and Open Updater
  3. Start update

The output of your Nextcloud log in Admin > Logging:

Nothing related to update. Just some old (from last week) logs.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

Not required.

The output of your Apache/nginx/system log in /var/log/____:

Not required.

I deleted the nextcloud.log file which was empty anyways. But I am not sure if it is a good idea to delete the entire cache folder. I thought this folder is part of Nextcloud installation. I did not manually add it. And also whenever I retry the upload, nextcloud.log is created automatically. So I’m not sure what’s really going on here.

Any thoughts on this issue I am having?

just searched the forum… and so i came up with
this and that
and maybe even more…

Thank you for trying to help but as I said in OP, deleting the log file does not correct the problem for me. In addition, I do not have the Logging extension enabled.

I have exactly the same problem. Last time I fixed it by manual update but it’s annoying that I have to do it again now.
I think that logging to syslog and deleting nextcloud.log could help. link
Nevertheless I don’t have chance to try it today, but as soon as I try it, I’ll let you know.

Yep, changing log type to syslog type and then deleting nextcloud.log worked perfectly for me. :slight_smile:

I guess that you can just delete cache as I don’t see it in my nextcloud folder.

Hope your update will be successful.