Unable to sync contacts

CardDAV sync does not work with MacOS. Unable to verify.

Strangely, CalDAV works fine. I used the URL provided in NC settings

here are the deets if you want to try it yourself:
user: troubleshoot
pw: ML5Qb66n7wG2cHQ

nextcloud. 20.0.5
MacOS 11.3.1
contents of my htaccess file:
# php – BEGIN cPanel-generated handler, do not edit
# This domain inherits the “PHP” package.
# php – END cPanel-generated handler, do not edit

AddHandler cgi-script .py
Header always set Strict-Transport-Security "max-age=31536000; includeSubDomains; preload" env=HTTPS

RewriteEngine on

# Nextcloud
RewriteRule ^\.well-known/host-meta /cloud/public.php?service=host-meta [QSA,L]
RewriteRule ^\.well-known/host-meta\.json /cloud/public.php?service=host-meta-json [QSA,L]
# RewriteRule ^\.well-known/webfinger /cloud/public.php?service=webfinger [QSA,L]
RewriteRule ^\.well-known/webfinger https://%{SERVER_NAME}/cloud/public.php?service=webfinger [QSA,L]
RewriteRule ^\.well-known/carddav /cloud/remote.php/dav/ [R=301,L]
RewriteRule ^\.well-known/caldav /cloud/remote.php/dav/ [R=301,L]

# BEGIN WordPress
# The directives (lines) between "BEGIN WordPress" and "END WordPress" are
# dynamically generated, and should only be modified via WordPress filters.
# Any changes to the directives between these markers will be overwritten.
<IfModule mod_rewrite.c>
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

Have you tried as server address only the domain without subdirectory (mountainmanjoe.ca)?

1 Like

Thanks Bernie. It accepted that setting without verification error.(it that case Nextcloud shouldn’t be suggesting incorrect settings). But my contacts still aren’t being synced.

Hm. I just added your troubleshoot account to my MacOS and the contacts get synced (both directions). I am on MacOS 11.4 though - but I doubt that this makes a difference. I did use Nextclouds contact sync also with MacOS 11.3.1 without any troubles.

EDIT: do you use any programs manipulating the network traffic (firewall etc., e.g. littlesnitch)?

1 Like

no, I don’t

bump. any other ideas?

I tried setting it on my iPhone and no love there either.

OK I just tried again using my mobile data and it worked. I’ve contacted my hosting provider to see what’s going on . This wouldn’t be the first time they’ve blacklisted my IP. Their security is so aggressive.

confirmed. Hosting provider blocked me in firewall. Works fine now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.