Unable to share [SOLVED]

Nextcloud version (13.0.6) :
Operating system and version (Ubuntu 18.04) :
Apache version (Apache 2.4.29) :
PHP version (7.1.18) :

The output of /var/www/html/nextcloud/config/config.php :


$CONFIG = array (
‘instanceid’ => ‘xxx’,
‘passwordsalt’ => ‘xxx’,
‘secret’ => ‘xxx’,
‘trusted_domains’ =>
array (
0 => ‘’,
1 => ‘xxx’,
2 => ‘xxx’,
3 => ‘xxx’,
‘datadirectory’ => ‘/mnt/files/data’,
‘overwrite.cli.url’ => ‘’,
‘htaccess.RewriteBase’ => ‘/’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘xxx’,
‘dbpassword’ => ‘xxx’,
‘installed’ => true,
‘skeletondirectory’ => ‘’,
‘auth.bruteforce.protection.enabled’ => true,
‘mail_from_address’ => ‘nextcloud’,
‘mail_smtpmode’ => ‘sendmail’,
‘mail_smtpauthtype’ => ‘LOGIN’,
‘mail_domain’ => ‘xxx’,
‘maintenance’ => false,
‘updater.secret’ => ‘xxx’,
‘theme’ => ‘’,
‘loglevel’ => 2,
‘updater.release.channel’ => ‘stable’,

The output of /etc/apache2/sites-available/nextcloud.conf:

<VirtualHost *:80>
 ServerAdmin xxx
 DocumentRoot /var/www/html/nextcloud/
 ServerName xxx
 ServerAlias www.xxx

 Alias /nextcloud "/var/www/html/nextcloud/"

 <Directory /var/www/html/nextcloud/>
    Options +FollowSymlinks
    AllowOverride All
    Require all granted
      <IfModule mod_dav.c>
        Dav off
    SetEnv HOME /var/www/html/nextcloud
    SetEnv HTTP_HOME /var/www/html/nextcloud

 ErrorLog ${APACHE_LOG_DIR}/error.log
 CustomLog ${APACHE_LOG_DIR}/access.log combined

RewriteEngine on
RewriteCond %{SERVER_NAME} =www.xxx [OR]
RewriteCond %{SERVER_NAME} =xxx
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

screenshot of settings


Sharing is broken.
I have a snapshot of my server from few month ago and sharing works on it, but I can’t rollback, I need to be on this server.

When I click “Share a link” I see only circle (see screenshote).
I also can’t share with a user, I type name and don’t see autocompletion.

I tried to reboot server, it does’t help. I tried to dissable sharing and turn it on again, nothing.
I have no errors in my Logging.
Please, help me to solve this problem.

Which browser? Any script blocking addons active?

Firefox 61.0.2 or Chromium 69 the same issue.
Adblock is dissabled.
I have snapshop from a month ago and it works correctly.

Just checked with v14.0.3 and my setup looks nearly like yours.

Your snaphot:
Which version is inside?

If version differ:
Have you checked changelog?
Have you checked issues at GitHub?

1 Like

The version is the same - 13.0.6 :frowning:
I made snapshot before I installed fail2ban on Ubuntu.
As I remember I did’t made any changes connected to Nextcloud.

You could try to delete all Cookies in your browser and on the server delete all sessions in your php session directory and with occ delete the file cache, make a new file scan and a maintenance repair

1 Like

I tried everything:

  • reboot OS when Nextcloud installed
  • reboot Proxmox, when VM with Nextcloud installed
  • different browser
  • disable extensions in browser
  • delete cookies and history from browser
  • play with Nextcloud settings connected with shares
    Result - nothing

But few days ago I find out that my OS with Nextcloud have 1GB of RAM
and it use almost everything.
I added 600mb more, turned off, turned on VM and now SHARE IS WORKS correctly
I don’t know if this connected, but it is the only thing that was changed.

Thanks everyone for support!