Unable to share anything after new install

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 28.0.2
Operating system and version (eg, Ubuntu 20.04): Debian 12
Apache or nginx version (eg, Apache 2.4.25): 2.4.57
PHP version (eg, 7.4): 8.2.7

The issue you are facing: After a installing and setting up Nextcloud on my Debian 12 system everything seems to be working fine. However, I’m unable to share anything. I have been through the sharing options and they look fine, but when I go to files->shared with others the “+ add” share is greyed out and hovering over it says “You don’t have permission to upload or create files here”. I’m logged in as the administrator.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Log in as administrator
  2. try to share something

It looks like a permission problem.
The folder that you are using (from where you want to share a folder or file) is an external storage?

  • Login as administrator
  • Go to Administrator Settings
  • Go to External Storage in the administration Section (not the personal Section!)
  • go to the specific storage location. There use the menu (with the 3 dots) and select the sharing option ‘Enbale Sharing’

Please let us know what the result is…

Hi, Thanks for the reply. Yes, it’s an external storage device. Yes, I have already enabled sharing on external device. I also created another directory (not on the shared device) and I’m unable to share that either. Basically I can’t share anything there are no error messages the option to share is simply greyed out.

OK. Thanks.
I assume that also the default settings are checked and Create, Change, Delete and Reshare are enabled.

Can you confirm that

  • the ownership of the folder is set to www-data:www-data
  • that the folder on the disc is having the right permission? 770 for example

Good luck and please let us know what the results are.

Yes, in the Adminstration->sharing Create, Change, Delete and Reshare are all enabled. I have disconnected the external storage. I have successfully created a new folder called test-share and I have uploaded some files to this folder successfully. The permissions on this folder are 775. However, when I go to “share with others” the “+ add” file is greyed out and hovering over says " You don’t have permission to upload or create files here" I’m baffled!

Interesting problem.
It might a bit annoying to ask, but we need to find out the what causes the problem that you are facing. So please bare with me.

Can you tell me what the configuration is with expiration dates of the shared files?

  1. Did you enable ‘Allow Apps to use the Share API’?
    – If this is not checked, no users can create file shares!

If this setting is not solving the problem that you are facing, we have the find a solution somewhere else. Knowing that there are reports of expiration dates of shares, I need to know the following settings.

  1. Did you enabled ‘set default expiration date for shares’? on the Admin Page in the Sharing Section?

  2. Did you enable ‘Enforce expiration date’?

  3. Did you enable ‘Allow sharing with groups’?

Hi BlueBee, I’ve just done a complete fresh re-install and the problem remains. In answer to your questions
Did you enable ‘Allow Apps to use the Share API’? YES
Did you enabled ‘set default expiration date for shares’? on the Admin Page in the Sharing Section? NO
Did you enable ‘Enforce expiration date’? I can’t see this option, as “set default expiration date for share” is NOT enabled
Did you enable ‘Allow sharing with groups’? Yes

I think this must be a bug in the file sharing app

Are you sure you’re looking in the right spot?

I typically share by clicking on the sharing icon on the individual file entry in the main Files page. I don’t believe one has ever been able to share from the Shared with others section of the sidebar. That area just shows what you’ve already shared.

AAhhh Yes, now I see! I was confused by the “+ add” button on the “share with others” Now I feel really stupid!:stuck_out_tongue_winking_eye: :stuck_out_tongue_winking_eye:
Thanks!

1 Like

No worries. In your defense, that disabled Add button wasn’t even visible in the older UI (<v28). It does seem confusing. Maybe it shouldn’t even be there at all.

Yes, I actually worked it out myself before i saw your reply. I did it by installing a virtual machine with Kubuntu and installing the snap package. As soon as I did that I realized my mistake. The snap package is using v27 and there are two differences one is as you mentioned the redundant “+ button” is not there and secondly the share icon next to the folders in the file view is a “share icon” and not a little head with a “+”. Making the whole thing much more obvious. Not sure why the icon was changed or the purpose of the “+ add” button.

1 Like

Nice you have figured it out.
The share folder is actually another folder, the folder called ‘Appdata’
Appdata is a folder inside of the data directory which contains files that are shared between users and can be put there by the server or apps like avatar images, file previews and cached CSS files for example.

Assuming only the NC system can actually use this folder, no user will have access to this folder. The idea behind the grayed out ‘+’-button is unknown.