Unable to select share links on iOS

I am having trouble selecting and copying share links on Next Cloud Web UI using browsers on IOS.

For example, when I click “…” next to a calendar, then select “link”’ I see a text field with the link appearing below. However, I’m unable to select the link within the field to copy. Short tap or long tap will result in a word within the link to be selected and the context menu does not show option to select or select all.

The text field is very small so most of the link URL is hidden, trying to tap+hold+swipe right does not scroll the cursor, so I’m not able to scroll to see the entire URL for manual entering either.

I’ve tried this with Safari, Chrome, and the Firefox browser with the same behavior. Behavior is also the same in Calendar and Contacts app, I haven’t tried with other apps. Seems it’s an issue with the type field box being used, or maybe there’re scripts attempting to shift focus or doing auto-selection that’s messing with the iOS native text selection behaviors. It may also be that the text field is really disabled that’s causing this behavior. I’m just guessing, please let me know if I’m doing something wrong.