Unable to mount smb share

I m trying to mount an SMB Share on a Windows 10 LTSB 1607 client via the external storage app.
However, I always get the red circle with the exclamation mark (why is there no error message on this screen?!).

The “Logging” section says: Icewind\SMB\Exception\ConnectionException: Connection not valid

What I already tried (gathered from various other threads):

  1. apt-get install smbclient (smbclient/disco-updates,disco-security,now 2:4.10.0+dfsg-0ubuntu2.8 amd64 [installed])
  2. apt install php-smbclient (php-smbclient/disco,now 0.9.0-3 amd64 [installed])
  3. tried modifying /etc/samba/smb.conf with:
    client min protocol = SMB2 client max protocol = SMB3

I entered the smbconfiguration without any Slashes or Backslashes (so in “host” I only have the hostname of the device and in “share” only the sharename).
I can mount the share successfully from another Ubuntu client where cifsutils is installed.

NC: 18.0.2
external storage support: 1.9.0

Does it work when you mount it locally in ssh?

I cannot mount the share locally on that system, as there is no cifs-utils installed.
Message I get is:
mount: /media/test: bad option; for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount.<type> helper program.

I tried that before, however I am unsure if this is a valid troubleshooting step, as from my understanding, NC tries to mount it somehow via php (and not via cifs-utils).

Install it…

Installed it and (as expected) makes no difference at all (same error in logs).
It wasnt mentioned anywhere as requirement in any documentation.
Just out of curiosity: what made you think it was needed?

However, I can now mount the share successfully from the console of the OS.

No one else got any ideas? Seems to be a pretty common issue.

Lots of answers on this forum then…

What log level do you have enabled in your config.php?

Still getting this issue, still no resolution.

Mounting the share on the console works fine, so my workaround for now is to mount the share in the OS and then use a “Local” share in the external storages app.

However, this is of course not how it is supposed to work. At the moment I assume that NC smb-mount implementation is broken / flawed in some way, which is very unfortunate.
Please try to prove me otherwise (and please, no random “I have no clue what it does, but please try this”, dont waste our time).