Unable to load Page NextCloud "Index of /"

Hi everyone,

[/details]

Nextcloud version (eg, 20.0.5): 28.0.2
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.0.4
Apache or nginx version (eg, Apache 2.4.25): 2.4.52
PHP version (eg, 7.4):8.1.2

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): YES

Steps to replicate it:

  1. I’m browsing my Nextcloud using internal IP show that “Index of /”

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'passwordsalt' => 'X7Ncsht4XXXXXXZa3f0QKbe',
  'secret' => 'BekI0zL7lgD3obvpXydhnMETSoaO4L/i0QX70RTmPwUb/nA5',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => '172.17.17.104',
    2 => 'nextcloud',
    3 => '202.186.71.117',
    4 => 'mydomain',
  ),
  'datadirectory' => '/mnt/ncdata',
  'dbtype' => 'pgsql',
  'version' => '28.0.2.5',
  'overwrite.cli.url' => 'https://mydomain',
  'dbname' => 'nextcloud_db',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud_db_user',
  'dbpassword' => 'RXXX',
  'installed' => true,
  'instanceid' => 'ockxybrbdnj5',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => '0',
    'dbindex' => '0',
    'timeout' => '0.5',
    'password' => 'XXXXX',
  ),
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'upgrade.disable-web' => true,
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => '2',
  'log.condition' =>
  array (
    'apps' =>
    array (
      0 => 'admin_audit',
    ),
  ),
  'mail_smtpmode' => 'smtp',
  'remember_login_cookie_lifetime' => '1800',
  'log_rotate_size' => '10485760',
  'trashbin_retention_obligation' => 'auto, 60',
  'versions_retention_obligation' => 'auto, 180',
  'activity_expire_days' => '120',
  'simpleSignUpLink.shown' => false,
  'default_phone_region' => 'us',
  'logtimezone' => 'Asia/Kuala_Lumpur',
  'htaccess.RewriteBase' => '/',
  'maintenance' => false,
  'twofactor_enforced' => 'true',
  'twofactor_enforced_groups' =>
  array (
    0 => 'admin',
  ),
  'twofactor_enforced_excluded_groups' =>
  array (
  ),
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'username',
  'mail_domain' => 'live.com',
  'mail_smtphost' => 'smtp-mail.outlook.com',
  'mail_smtpport' => '587',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'Xx@live.com',
  'mail_smtppassword' => 'vabdsrasyvrqmqqp',
);

The output of your Apache/nginx/system log in /var/log/____:

Apache
https://pastebin.com/tjarD6SU

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

https://pastebin.com/tjarD6SU

Sounds like your Apache VirtualHost configuration. You need to review what you have configured in Apache.

Managed to resolved it. apache issues set sited enabled

1 Like