Unable to install Talk via VM script

I’m trying to install Nextcloud Talk via the VM script (nextcloud_install_production.sh / talk.sh) but am getting the following error when I try:

It seems like Nextcloud is not installed or that you don't use https on: cloud-hostname

So I’m using this script on a VM, with an Apache reverse proxy on another VM which points to this one. It seems to work fine, since after installing NC this way I can access my instance without problem, and via HTTPS without error, which I believe shows that the proxy and associated virtual hosts are working fine.

EDIT: Due to this setup, the SSL certificates for this instance are hosted on the other ‘landing’ VM, and not the VM with NC installed.

What I don’t understand is that the error looks to be trying to connect to my hostname via https, and not the actual web address. If it were to be looking at https://cloud.hostname.xyz it would see a Nextcloud install that it literally just created.

How do I change the script so that it looks at the web address and not the hostname? I tried to change the hostname to the web address, but then the error had ‘localhost’ instead of ‘cloud-hostname’, so didn’t get anywhere there.

Thanks in advance for any help.

As an update to this, I edited the config.php file, which had the ‘overwrite.cli.url’ set to ‘http://cloud-hostname/’, so I changed it to what it should be, ‘https://cloud.hostname.xyz’. When running talk.sh, it now shows the correct URL, but STILL comes up with the same error.

Since I always skipped the SSL setup since the landing VM has the SSL certs for this server, I went about setting it up anyway to see if it made any difference. It didn’t.

Any hints to what is preventing the NC Talk script from detecting I have a NC install already with SSL?

The Talk script is designed to be run with the VM defaults, which means that it will reuse the SSL from Let’s Encrypt (and that path).

If you don’t use Let’s Encrypt, then you have to change SSL in the config file for coturn as well, plus some other changes that I don’t remember from the top of my head right now.

The check for the domain is here:

As you can see it check in config.php, so if that isn’t correct the check will fail. Everything like that is automated if you run Let’s Encrypt…

If you need hands on support, you can always opt in for this.

Thanks for your reply. Not sure if I’m being dense, but I don’t quite understand. I do have a LE cert for this VM with NC installed, but it’s on a landing VM where the Apache reverse proxy is installed.

Would love to be able to purchase support to help with this, but the price is much too high for me.

I’ll have a fiddle and see what I can do, but most likely I’ll go back to a manual install.

I mean the LE in the VM, it’s not the same as in the proxy.

If you want to use the same certs on the backend host I recommend this: https://www.techandme.se/share-lets-encrypt-ssl-certificates-between-hosts/