Unable to get LDAP to work

Nextcloud version : Latest (11.0.2)
Operating system and version: 16.04
Apache or nginx version : Caddy (latest)
PHP version (eg, 5.6): 7.0.15

I installed the LDAP module from the app store. But I can’t get the app to work. I tried almost every possible configuration I could think of and the current one looks like the following:

My Active Directory is cludch.net and the user CLUDCHNET\nextcloudadmin /nextcloudadmin@cludch.net is the domain administrator. The password is correct.
Weirdly, I can’t even use detect port.
When I click Continue it tells me that it could not connect to the LDAP server.

My logs are being spammed by the following:

{"reqId":"wIlxqR1vE8mmNpVWdp15","remoteAddr":"","app":"user_ldap","message":"Configuration Error (prefix s01): login filter does not contain %uid place holder.","level":2,"time":"2017-04-09T10:21:00+00:00","method":"GET","url":"\/index.php\/login","user":"--","version":""}
{"reqId":"wIlxqR1vE8mmNpVWdp15","remoteAddr":"","app":"user_ldap","message":"Configuration Error (prefix s01): No LDAP Login Filter given!","level":2,"time":"2017-04-09T10:21:00+00:00","method":"GET","url":"\/index.php\/login","user":"--","version":""}

Even though this looks like an error, which is being thrown, because I did not finish the configuration.

I got very little knowledge of AD etc. but I hope that you can help me.

Thanks in advance,

I’d bet, that cludch.net is not the AD’s full name - it’s a domain. You will have to enter the hostname of that AD completely, e.g. ad.cludch.net - or try it’s IP number…


That shouldn’t be the issue.
Internally the domain resolves to the AD Host. I also tried the hostname and ip.

Ok, after disabling the AD server’s firewall, detect port works but Detect/Test Base DN doesn’t.