Unable To Delete/Rename/Move anything on nextcloud instance that has been active for 2 years

Nextcloud version (eg, 20.0.5): 25.0.2
Operating system and version (eg, Ubuntu 20.04): Debian 11
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.54
PHP version (eg, 7.4): v8.1.13

The issue you are facing:

So recently all my apps were updated and ready for the v25.0.X update. So I updated nextcloud and i am now running v25.0.2.

Before updating; everything worked perfectly, I could upload to the nextcloud instance, rename files, delete files if needed. On all my Devices Linux (Desktop), Windows, iOS and Android devices.

Now on all devices I can add/create files but cannot rename, move or delete. It simply says “Error Deleting filename” or on my iOS devices “Write access to end-to-end encrypted folder requires token - no token sent”. The exact same device that was able to add and delete/rename/move files cannot do it.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. No clue on how to replicate this issue

The output of your Nextcloud log in Admin > Logging:

Just found out that the admin logging page does not load. it displays on page load and clears after 1 second

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'instanceid' => 'instanceID',
  'passwordsalt' => 'passwordSal',
  'secret' => 'secretKey',
  'trusted_domains' =>
  array (
    0 => 'cloud.mydomain.com'
  'trusted_proxies' =>
  array (
    0 => '',
    1 => '',
  'enable_previews' => false,
  'allow_local_remote_servers' => true,
  'skeletondirectory' => '/var/www/nc-skeleton',
  'overwriteprotocol' => 'https',
  'defaultapp' => 'dashboard',
  'knowledgebaseenabled' => false,
  'remember_login_cookie_lifetime' => 86400,
  'session_lifetime' => 86400,
  'session_keepalive' => true,
  'auth.bruteforce.protection.enabled' => true,
  'default_phone_region' => 'US',
  'datadirectory' => '/var/www/nc-storage',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://cloud.mydomain.com',
  'dbname' => 'db_name',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'db_user',
  'dbpassword' => 'db_pass',
  'installed' => true,
  'filelocking.enabled' => true,
  'filelocking.ttl' => 3200,
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '',
    'port' => 6379,
    'dbindex' => 0,
    'password' => '__________',
    'timeout' => 0,
  'mail_from_address' => 'no-reply',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'mydomain.com',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpsecure' => 'tls',
  'mail_smtpport' => '587',
  'mail_smtphost' => 'smtp.mydomain.com',
  'mail_smtpname' => 'no-reply@mydomain.com',
  'mail_smtppassword' => 'secret password',
  'maintenance' => false,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'tempdirectory' => '/var/www/nc-storage/tmp/',
  'theme' => '',
  'loglevel' => 0,

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

Windows Trying to delete file log : https://pastebin.com/fPpJtgQw returns a 403 but in logs it shows something else.

iOS trying to delete file log: https://pastebin.com/yVNsTWfb

What I have tried is to disable redis caching and file locking, removed all file locks from db and still the exact same error.

I have also tried ./occ files:scan --all as well as files:cleanup

I have no idea how to fix this as this is the first time this has occurred.

if more information is required please ask :slight_smile:

Thank You for your assistance