Unable to connect to ldap (samba 4.5.1)

Nextcloud version (eg, 10.0.2): 11.0.1
Operating system and version (eg, Ubuntu 16.04): Debian 8.6 (jessie)
Apache or nginx version (eg, Apache 2.4.25): 2.4.10
PHP version (eg, 5.6): 5.6.24
Is this the first time you’ve seen this error and can you replicate it?: first time, it was working when i had my LDAP Users on Windows Server 2012 but now i am using ZENTYAL SERVER 5.0

The issue you are facing:

I am unable to connect my Nextcloud to LDAP Server is ZENTYAL SERVER 5.0 which use samba and openldap.

I have try both of those setup (This is a lab so those domain doesn’t exist) :

dc01.stepuzzle.com port 389

dc01.stepuzzle.com port 389
empty (auto detect doesn’t work because it can’t connect to ldap)

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

default one with my trusted domains

The output of your Apache/nginx/system log in /var/log/____:

I can’t copy paste because my VMWaretools doesn’t work :s

Remember, this information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart: Feel free to use a pastebin service, otherwise log files can be indented with 4 spaces on each line to present them in a friendlier way on the forum.

I know this is old but I was having the same issues with Zentyal 6.1 and Nextcloud 17. I was unable to figure out how to fill in the credentials.
I tried several variations of the uid=domain admin,cn=domain administrators,dc=mydomain,dc=com
or just the UID= or just the username domain admin… none worked.

The iexamples in the tool tip are frankly misleading. Because the one that worked for me was simply using the domainadmin@mydomain.com format.