Unable to change user password from admin

Hi team,

Has anyone faced the issue where you are unable to change a users password from the admin panel?

I believe the correct method is to:

  1. click the pencil
  2. enter password
  3. hit return/enter

However it appears the password is not saving.

I’m using VestaCP.

Thanks

2 Likes

Hey @Jamie_Le have you tried to hit enter after you changed it? And how about going to the user panel (personal page) of the admin and changing it there?

If both don’t work please post the content of your nextcloud log file.

Hi there,

i have the same problem. Even hit enter after changing… in the console of my browser i got a 503 Error for requesting the following URL: https://<myhost.com>/index.php/settings/users/changepassword

Thanks,

NilO

@NilO: Can you check your webserver logfiles?

Hello, I tried to change an password from an user. I can edit the passwordfield but after hit enter. Nothing happens.

Same issue here. Running 11.02. This is a serious issue.

I can’t reproduce this on the current 11.0.2 version. If the password is not complex enough it shows an error on the top saying why it is not secure. But as admin I can change a user’s password.

Please provide more information about your setup. Version used, enabled apps, use of encryption app, external authentication, … and logfiles.

I was struggling with this as well, but got it worked out. I think the key is: You might need to press Enter twice. Or at least I had to, and only THEN will the admin panel try and update the password, including messages about insufficient complexity (in the very very top of your screen) or confirmation.
Do try. :slight_smile:

1 Like

mine used to work and now im not longer getting that message on top

Hi All

Just downloaded and installed NextCloudPi which bundles NextCloud12 on a Raspberry Pi 3, (Very good experience and hats off to nachoparker for his efforts here! Thanks!).

Got it all up and running fairly easily but now find myself with same situation as many on this thread. Trying to do any admin tasks (change password, add a group) prompts for a password. The only user on the box is admin and thats the account I am logged in as, so thats the password I enter. Unfortunately when I click “confirm”, it simply reverts to an empty box suggesting I try another password. If I enter an incorrect password then a message pops up on the blue menu bar advising of failed authentication adn to try again. The fact that I get no failure message when entering in the original admin password implies that it doesn’t find fault with it,… but it actually doesn’t do anothing other than reset the password box inviting another try.

So in summary, am stuck in a loop. I can log in and out as admin using the standard admin password but when it comes to doing any admin tasks, it is not accepting and allowing those tasks using the same password.

Any suggestions?

Thanks in advance

It doesn’t help to complain like this. Please open a topic on github.com/nextcloud/server/issues and provide more information about your setup in order to reproduces this error.

Hi tflidd

Thanks for the feedback. Just wanted to update that I solved the problem and share some thoughts on your feedback

Solution The issue was that my Pi time and date were off by 9 hrs (even though I have set the Time zone correctly using raspi-config). I suspect this was causing the authentication process to fail somehow when trying to set up new users as the Pi admin. After googling a “how-to”, I manually set the Date and Time correctly, rebooted and the problem was solved.

Your Feedback on using this forum vs github: I’d like to offer the following.

Sorry that the post came accross as a complaint, that certainly wasn’t the intention and I am struggling to see how it can be perceived as one.

  • Paragraph 1 is a complement to the Nextcloudpi project instigator,… he certainly deserves it
  • Paragrpah 2 factually tells you what i did and shares that it is NextCloud12 " that had been “just downloaded”. So that gives the various version numbers for a user perspective.
  • Paragraph 3 simply states that I was in a loop and asking if there were any suggestions.

Please reflect that the NextCloudPi project appears to be moving in the direction of bundleing multiple opensource utilities into a more shrink wrap deliverable to reduce the complexity and expand the userbase (one of nachoparkers objects I read somewhere). A biproduct of this commoditization is that the userbase becomes less experienced/familiar with the constituent parts… and that’s ceratinly a good description of me. Having looked at github, it seems to be a repository for pretty detailed technical bug reporting and active opensource development. Not something I spend a lot of my time doing. I understand the need for detailed descriptions to replicate bugs but sometimes “root cause analysis” can yield quite simple solutions, (as in this case). A forum like this one seemed to be a good place to start,… it was germane to my issue, appeared to have a community of willing participants and there were no pointers in the thread to suggest that it would be the wrong thing to do.

Hope you have a good weekend and keep up the good work with NextCloud. Kind Regards

Don’t mean to necro the post but you still have to do this as of current version April 2021

1 Like

Version 21, RPI4, docker. Thank you! This solved it for me too. Except I’m very hesitant to “manually” set a time anywhere. Thats what time servers are for. So I double-checked “raspi-config.” I had set the time to “America” (true), as it is with all docker environmental variables, but I should have set it to “US.” Then I selected the timezone, rebooted, and I’m able to change passwords via admin GUI.