Unable to access AIO Interface for upgrades

I recently reinstalled Nextcloud AIO because I messed it up playing around in my Ubuntu server. It’s a whole fresh install, new server, everything.

My domain is hosted at Cloudflare, and I forward the domain to my home IP address. I’ve never had a problem doing this with AIO, except this time I had to change the subdomain because I reached the limit for the current subdomain I was using for Nextcloud.

I can log in and use everything just fine, but when I try to update the instance, I can’t access the AIO Interface to stop the containers, do the update, etc.

I was getting an error that said “NET::ERR_CERT_AUTHORITY_INVALID”, then if clicked on that it would show me a certificate (probably self-signed), and then the page said

subdomain.domain.tld normally uses encryption to protect your information. When Brave tried to connect to subdomain.domain.tld this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be subdomain.domain.tld, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Brave stopped the connection before any data was exchanged.

You cannot visit subdomain.domain.tld right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later."

I tried using ChatGPT-4 (terrible idea) to teach me how to fix it, and it suggested that I go to brave://net-internals/#hsts and delete the domain security policy.

Well, it didn’t work. Then it suggested I try using HTTP vs HTTPS, so I told it that’s not possible (GPT claims to be familiar with Nextcloud AIO, supposedly).

Then it suggested I create my own self-signed certificate and import it into brave, so I tried it and didn’t work either.

Then it suggested I activate HSTS in Cloudflare, which I did, and that didn’t work either.

Now when I access the AIO Interface, I get a new error page:

Lastly, if I leave the admin overview page on display, it will eventually show an error checking the server’s setup:

Can anyone help me un-mess-up? I really don’t want to reinstall the whole server just for this. I already ran out of Let’s Encrypt certificates for several subdomains messing up before.

If you need a verbose log, when I get home I can set the logging to verbose to get more data. At the standard level, the log doesn’t show anything about this.


I would maybe not use a chat bot to troubleshoot an issue like that… Especially not after seeing Bing’s adaptation of it go insane and start threatening users.

HSTS tells the browser not to connect to that website without HTTPS for some period of time (usually very long, I think they recommend 6 months), and to not accept the certificate of it becomes invalid.

So you can potentially override that in the browser, or use a different browser that hasn’t been to the site before.

You will need to stop the apache container with sudo docker stop nextcloud-aio-apache, open the AIO interface at https://public.ip.address.of.this.server:8080, log in with the AIO password and restart all containers from there in order to fix this.


Yes, lesson learned! Szaimen knows better than ChatGPT.

1 Like

Now I get this. Let me know if I should do anything about it, or assume the next update will make it go away.

One of the next updates will update the included AIO app to be compatible with Nc26. We are tracking the current process here: tasks for nc26 · Issue #2336 · nextcloud/all-in-one · GitHub

I have the same issue, but when I try:

sudo docker stop nextcloud-aio-apache

I’m getting the error:

Error response from daemon: cannot stop container: nextcloud-aio-apache: permission denied

I don’t want to kill the container because then I’ll lose my configuration that has been working apart from accessing the AIO portal

sounds like something is broken with your docker daemon installation then. This is unrelated to AIO.

But if I can start and stop other containers, even the AIO container for example, would that not mean my daemon is fine, and that it’s an issue with the apache container?

Have you installed docker via snap?

I found this: ruby on rails - Docker Containers can not be stopped or removed - permission denied Error - Stack Overflow

no just the normal apt install using the github instructions:

I see. Can you try if ruby on rails - Docker Containers can not be stopped or removed - permission denied Error - Stack Overflow helps?

1 Like

That worked, I guess it was installed via snap during the install.sh and I didnt realise.

Thanks so much!

Hi @szaimen , I’m still with the issue from the post and image above. I think the Github issue should be resolved. I cannot access the AIO Interface by clicking the button, or at my-public-ip.com:8080, even after a ‘sudo docker stop nextcloud-aio-apache’.

Let me know what you think I should do. Thanks.

1 Like

Hi, please create a new thread for this.

1 Like