Ubuntu Nextcloud + Nginx Proxy Manager - You are accessing your instance over a secure connection, however your instance is generating insecure URLs

Hello!

Nextcloud version: 28.0.2
Operating system and version: Ubuntu 22.04
Apache or nginx version: Apache/2.4.52
PHP version: Version: 8.1.2
Database: mysql 10.6.16
Nginx Proxy Manager

The issue:
You are accessing your instance over a secure connection, however your instance is generating insecure URLs. This most likely means that you are behind a reverse proxy and the overwrite config variables are not set correctly.
Problem with access to Nextcloud from Android device - HTTP mode.

config.php:

<?php
$CONFIG = array (
  'instanceid' => 'oc**REDACTED**',
  'passwordsalt' => '**REDACTED**',
  'secret' => '**REDACTED**',
  'trusted_proxies' => 
  array (
    0 => '192.168.254.14',
    1 => 'localhost',
  ),
  'overwritehost' => 'cloud.aaatech.site',
  'overwriteprotocol' => 'https',
  'overwritecondaddr' => '^192\\.168\\.254\\.14$',
  'overwrite.cli.url' => 'https://cloud.aaatech.site',
  'trusted_domains' => 
  array (
    0 => 'cloud.aaatech.site',
    1 => '192.168.254.14',
  ),
  'forwarded_for_headers' => 
  array (
    0 => 'HTTP_X_FORWARDED',
    1 => 'HTTP_FORWARDED_FOR',
  ),
  'datadirectory' => '/var/www/nextcloud/data',

Nginx Proxy Manager config:


Full advanced config:

client_body_buffer_size 1024k;
proxy_read_timeout 86400s;
client_max_body_size 0;
proxy_buffering off;
proxy_request_buffering off;
auth_basic off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
location /.well-known/carddav {
    return 301 $scheme://$host/remote.php/dav;
}
location /.well-known/caldav {
    return 301 $scheme://$host/remote.php/dav;
}

I read manual and other forums, but dont understand why https dont working correctly (((

Please help to config it!

Aynı sorunu bende yaşıyorum çözüm bulamadım, lütfen yardım.
(I'm having the same problem and couldn't find a solution, please help.)

This is not the correct syntax. Configuration Parameters — Nextcloud latest Administration Manual latest documentation

It’s also unlikely you need that entire line.

Also, you must disable Cache Assets on your NPM setup.

@sevketyazici -

You’ll need to post your config (occ config:list system) and describe your topology.