Ubuntu 18.04 not supported any more?

Please note: I know that developing a huge package like nextcloud is a lot of effort. I really appreciate your work!

I do have a nextcoud installation based on ubuntu-18.04. I’m running nextcloud 20.0.3. I realized that some extensions/apps are compatible with nextcloud 20 but not with my environment (mail, bookmarks?). These apps require php 7.3 which is not available for ubuntu-18.04.

I double-checked the system requirements page. It reads “ubuntu 20.04”, my older ubuntu version isn’t mentioned any more so it is probably not supported. I checked the history of the system requirements page. 18.04 was changed to 20.04 on October 6th.

For me, this is pretty bad since I have to migrate to ubuntu 20.04 now while being in the middle of the nextcloud 20 release cycle. I assumed that changes like these happen only when switching to a new major version of nextcloud. I think I could even live with such a change in the middle of a release as long as I get a warning a couple of weeks before. But maybe there was a warning and I missed it.

My wishes (maybe a bit ambitionated):

  • don’t change requirements within the middle of a nextcloud release
    (I know that you depend on 3rd parties like the php team, so this is hard to achieve)
  • or give a warning about changes in advance
    (maybe you did this but I missed it?)

It is normal that linux distributions and there realeases shipped with a “special” php software version. You get with Ubuntu 18.04 LTS php 7.2 . In livetime of Ubuntu 18.04 LTS you only get security updates for this version. This is normal.

8 months ago Ubuntu 20.04 LTS was shipped. Normally the server administrator changes the Ubuntu e.g. in the first year. If you upgrade you get php 7.4

If you do not like to upgrade from Ubuntu 18.04 LTS to 20.04 LTS then you must use your old php version or if necessary upgrade php with PPA from another source.

Read for example:
https://computingforgeeks.com/how-to-install-php-on-ubuntu/

1 Like

Thx @devnull for the explanation.

I cannot use the old php version since some apps don’t support it.

I don’t want to use PPAs since I don’t trust these.

In the end, I cannot use nextcloud 20 with ubuntu 18.04, so I have to upgrade which is a “surprise” to me at the moment. It hits me quite unexpected and that’s what I’d like to avoid in the future. But it may not be possible, I guess.

blocked.gif

You can use Nextcloud 19. It is also a stable and supported release.
You must not upgrade to Nextcloud 20. There are also users with Nextcloud 18.
You can use Nextcloud 19 until June 2021.

Unbenannt

No, I cannot. I upgraded to nextcloud 20 weeks before. I don’t want to downgrade to 19.

When I upgraded to 20, there was no hint that I might have tu upgrade to ubuntu-20.04 soon. That’s all I’m “complaining” about. But never mind, I’ll handle the situation somehow

blocked.gif

Ok. If “mail” and “bookmarks” really needs newer php versions than Nextcloud 20 i think you can better ask at the subfolders direct for this apps. Then there are not full compatible with Nextcloud 20. While asking in the subfolders post errors, logs and screenshots. Thanks.

mail: https://help.nextcloud.com/c/apps/mail/35
bookmarks: https://help.nextcloud.com/c/apps/bookmarks/53

Perhaps you get in this two subfolders also a solution for other incompatible apps.

Thx @devnull,

I originally contacted the mail app team. They don’t care. I don’t use the bookmarks app, I just got noted that they have the same requirement.

Maybe it is just a difference in the understanding of the appshop table? What does it mean when mail-1.7.2 appears right next to nextcoud 20? Does it have to be completely compatible? Or “partly compatible”?

I would not have run into the issue at all when the table mentioned only full compatible apps.

Never mind - I think I’m the only one who understands this wrong. Thx for your help!

blocked.gif

As already written in an other thread yesterday, the Nextcloud support for specific PHP versions ends as soon as a version reaches the end-of-life state. PHP 7.2 has been declared EOL on November 30th 2020.

The support periods and EOL dates for the PHP software are well communicated and you had enough time to keep your system updated. I haven’t yet seen any software company which tries to support a PHP version where the security isn’t guaranteed anymore, so why should Nextcloud do it?

The operating system is not that relevant. It’s just a recommendation. The PHP version on the other hand is important.

I understand that one don’t trust a random PPA with php packages. But https://deb.sury.org/ is actually the maintainer of the official packages and maintains a PPA (https://launchpad.net/~ondrej/+archive/ubuntu/php/) with packages for Ubuntu 18.04.

1 Like

Thx for explaining these.

I’m using an LTS version of ubuntu in order to keep it for a couple of years. In former times, I had bad experiences migrating to newer LTS versions too early, so I’m probably quite convervative related to this. Recommending ubuntu 18.04 without mentioning the upcoming issues related to the php version is not “the best” I can think of. On the other hand: Obviously, I’m the only one having issues with this and I will be able to handle the situation.

  • I will migrate to ubuntu 20.04

  • I will stop using certain apps to reduce the probability of running into this again

  • I will not examine the sources/maintainers of PPAs

Nevertheless thx for explaining details about the PHP PPA - good to know.

Best regards, Uli

Please keep up the good work, I appreciate it. Even when I don’t like everything.

blocked.gif

Thx for your response!

As already written in an other thread yesterday, the Nextcloud support for specific PHP versions ends as soon as a version reaches the end-of-life state. PHP 7.2 has been declared EOL on November 30th 2020.

Quite frankly: I don’t care. That’s why I don’t compile the packages on my own, like we did 25 years ago. I’m using an LTS linux release, so I don’t have to care, or do I?

The support periods and EOL dates for the PHP software are well communicated and you had enough time to keep your system updated. I haven’t yet seen any software company which tries to support a PHP version where the security isn’t guaranteed anymore, so why should Nextcloud do it?

So I have to look at all the dependencies nextcloud needs to run and keep an eye on their EOLs? I don’t think so. Within the installation guide, a LTS version of Ubuntu is recommended and my expectation was that

  • either it will be supported by nextcloud until its EOL (or maybe until the EOL of its universe packages?)

  • or I will get an information that I have to migrate

I don’t write this to offend you. These were just my expectations. They are wrong, I know now.

Best regards, Uli

blocked.gif

2 Likes