Ubuntu 16.04 fresh snap install nc13.0.4, webdav broken

I have a freshly installed and fully installed Ubuntu 16.04 Server and installed nextcloud 13.0.4. via the snap installation package. I followed the instructions here: https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-nextcloud-on-ubuntu-16-04 and am using a self-signed certificate.

I am not able to use WebDAV successfully on this server, but I am able to use the Nextcloud App available on Android Play.

When I attempt to use a generic WebDav client (I have tried several) I get an HTTP error 405.

I ran into this same problem a few months ago and gave up troubleshooting because the ubuntu nextcloud snap package makes changes difficult or impossible (e.g. you can’t just VI into files and modify them because snap makes the files immutable or otherwise unwritable.)

Any words of wisdom on how to resolve this issue?

I’m surprised there have been no responses here. WebDav is one of the key features nextcloud advertises and Canonical/Ubuntu partnership is at the top of their list… and no one else noticed this?