Ubuntu 16.04 crash after installing update


Just done an apt-get dist-upgrade on my ubuntu 16.04 workstation and nextcloud client now fails to start with a core dump. Error from client is below.

Version of new client is 2.5.0-20181111.015125~xenial1

Workstation OS is Ubuntu 16.04. NC server 14.0.3 on Ubuntu 18.04.

[1117/112347:ERROR:icu_util.cc(162)] Invalid file descriptor to ICU data received.
[1117/112347:FATAL:content_main_runner.cc(714)] Check failed: base::i18n::InitializeICU(). 
#0 0x7fbc69e66f1e <unknown>
#1 0x7fbc69e7dc3e <unknown>
#2 0x7fbc6906f4ad <unknown>
#3 0x7fbc68531efd <unknown>
#4 0x7fbc685333a5 <unknown>
#5 0x7fbc68537cd5 QtWebEngineCore::WebEngineSettings::initDefaults()
#6 0x7fbc6d88675b <unknown>
#7 0x7fbc6d8868c8 QWebEngineProfile::QWebEngineProfile()
#8 0x5643e848e4c7 OCC::WebView::WebView()
#9 0x5643e848d095 OCC::WebViewPage::WebViewPage()
#10 0x5643e848a021 OCC::OwncloudWizard::OwncloudWizard()
#11 0x5643e83fed1e OCC::OwncloudSetupWizard::OwncloudSetupWizard()
#12 0x5643e8403262 OCC::OwncloudSetupWizard::runWizard()
#13 0x5643e83f3a14 OCC::ownCloudGui::slotOpenSettingsDialog()
#14 0x5643e839978b OCC::Application::slotCheckConnection()
#15 0x7fbc64b3a308 <unknown>
#16 0x7fbc64b2ebb3 QObject::event()
#17 0x7fbc6799605c QApplicationPrivate::notify_helper()
#18 0x7fbc6799b516 QApplication::notify()
#19 0x7fbc64aff38b QCoreApplication::notifyInternal()
#20 0x7fbc64b545ed QTimerInfoList::activateTimers()
#21 0x7fbc64b54af1 <unknown>
#22 0x7fbc62337197 g_main_context_dispatch
#23 0x7fbc623373f0 <unknown>
#24 0x7fbc6233749c g_main_context_iteration
#25 0x7fbc64b557cf QEventDispatcherGlib::processEvents()
#26 0x7fbc64afcb4a QEventLoop::exec()
#27 0x7fbc64b04bec QCoreApplication::exec()
#28 0x5643e8381b5d main
#29 0x7fbc63c2e830 __libc_start_main
#30 0x5643e8381fa9 _start

Replying to myself…

Thought I’d check my other clients… Windows on 2.5.0 20181112 and Mac on 2.5.0daily 20181112 are both fine…

Tried the appImage install on Ubuntu 18.04 and it crashed, so tried the PPA and saw the notice about Ubuntu 16.04 no longer being supported fully which is probably my issue. :frowning:

Just working through some more testing on rolling back the client… This isn’t a major problem for me as I can just upgrade my desktop… I just have to figure out what I do for the piles of clients I put on a private nextcloud after the dropbox debacle who are all running 16.04. :frowning:

Who’d wanna work in IT? :smiley:

A bit more testing…

Per another thread, installing from the PPA does not work on Ubuntu 18.04, it hangs at the wizard. (Also the Appimage outright crashed, core dump)

Switched to using the snap for that 18.04 and aside from the credential issue it works fine, although back on 2.3.3 again, I’m guessing the snap build lags behind a little. (Credential issue fixed by snap connect nextcloud-client:password-manager-service)

On 16.04 rolling back the version on the PPA had a dependency error, so switched to snap there as well.

Installing snapd + nextcloud snap fixes the issue for 16.04 for the moment, working on a plan to change the clients to snap and not have to re-configure each client individually.