UB 18.04.2 LTS Nextcloud install (SMB and https:// .... config issues)

Hi there,

what im loking for is a really easy noob proof guide to install nextcloud on ubuntu 18.04 that does not need additional knwowledge and doesn’t stop randomly in between or skips important steps to accomplish sidegoal that i’ ll never use or understand?

Maybe you know of such a guide?

How about this? For Ubuntu 18.04 is the same with snap.

Thank you ill try that out

Hi there, my output looks like this (After installing smbclient and php-smbclient):

It seems i’m missing additional plugins?

thank you for your support and patience :slight_smile:

Hi there tried that and i got it working right away, including https. I assume this is the same install procedure you can select directly from the live cd (you get the option to install nextcloud with the ubuntu server installation itself). Snap i guess?

Sadly the error with smb is still not gone

May be you can try to added it? Because it is not listed on your screenshot.

Tried adding it but even after a restart the problem is still there.The function smb in nextcloud snap is not working and still displaying thta smbclient is not installed.

Im currently trying to mount a smb share from linux. Got that working today but not permanently
How to i make shure this smb share is connected at boot and is listed in nextcloud? (fstab)

Try to added in /etc/fstab something like this if you are using guest account:

// /media/NAS cifs guest,uid=1000,iocharset=utf8 0 0

–> Source.
Or like this if you have to authorize yourself:

//server/share /pathto/mountpoint cifs credentials=/home/username/.smbcredentials,uid=shareuser,gid=sharegroup 0 0

With .smbcredentials file in your home directory:


–> Source.

Do not forget to rescan it periodically, e.g. via OS cronjob:

Otherwise it will be updated only when you accessing it.

Cool thank you very much i’ll try that:)

Tried it and it kinda works but now im unable to scan the data via

“sudo nextcloud.occ files:scan --all”

The outpot after runing that is:

“cannot stat path of the current working directory: Permission denied”

And it seems as if i do not have premissions to write to that folder.

Damn this is not easy and not user (especially noob) friendly…

Thank you for the help!

Check this out, looks like it is exatly the same issue was solved here:

Hi thank you i’ll try that out.

In the meantime im fighting with fstab which mounted my share once and i could even write to it but after a reboot (without changing fsatb) ist won’t mount again…

I edited fstab , rebooted , was able to create a folder and a file, did another reboot and it broke…?

Now its throwing error 22 at me. if i run this:

tail -f  /var/log/kern.log

It complains about the SMBversion i guess ?

I believe you have 2 problems:

  1. Apparmor (or snap) give no access to nextlcoud, so it is “protecting” your folder.
  2. CIFS you should specify version of SMB, e.g. vers=1.0 for old one, e.g. try to put credentials directly without file .smbcredentials if it does not work -o username=username,password=password,vers=3.0. To be honest, I never added Samba via fstab, so I have no working config on hands.

Thank you for helping anyways :slight_smile:

I’ll try that out…

I need to find out what apparmour is… Must be some sort of protection but what folder is it protecting the share or the mountpoint folder. Andy why im doing this as sudo user?

Would I be correct in my suspicion that you installed using the snap package? If so, there is a serious design flaw in the snap package where it does not include smbclient, and you can’t add it. Installing it via apt does not make it available to the snap installation. The snap installation also has a strange procedure for enabling SSL if I recall.

If you really want to use SMB, you’re going to want install a different way. After finding out snap won’t do SMB, I tried a manual installation, but I was having fits out of Collabora at the time and ultimately moved my setup to docker-compose. Although the docker image also doesn’t include smbclient, you can easily add it or rebuild the image to include it.

You could try the Nextcloud VM, everything is prepared and you just follow the on screen instructions to set it up.

Happy Nextclouding!

In the interest of transparency, I’ll mention that enoch85’s VM is only free up to 40 GB of storage.

I actually do not need local sorage as i used to connect my smb nas to my owncloud. i want to keep the vm as tiny and uncomplicated in maintanance as possible.

But is it not possible to extend the hdd of that vm ?

I tried the vm on my esxi and i must say that its well prepared and has good config tuturials but … als a linux noob i must say that i wonder what i just installed. It has many different config “tools” that is offers to install. It gives me warnings that i do not understand? And i’m lost again …

What do i need to install and what, if possible, add later?

Tried it twice and on both installs i (must be me, not the vm install procedure) screwed up somwhere or something. The result is that that the installation finished but the nextcloud is not reachable.

As Docker or Kubernetes is something i do not want to screw arround with… jet, i’ll try the manual approach again. There must be an easy way to get this working…

!My Owncloud runs on UCS and inside a docker container which gives me headaces everytime something doesn’t work!

For now i’ll stick to the snap install and try to get this working. The mount works once and therefore it should work in general…

Linux … Why easy when you can do it the hard way … (This is a rant, so don’t take me to serious!!!)

It seems to be working right now.
I Followed a comment on the github Issues page of nextcloud/snap and i adeed a few lines to my fstab :

  • i know … you can see my ip and passwords… to lazy to edit :slight_smile:

This for some reason works and even after multiple restarts and poweroffs the share stays connected. How can i make shure this stays that way? I dont even need to refresh the filelist as it seems.

I can’t cd into the directory anymore? (This must be a premission thing “filemode and dirmode” ?

1 Like