Message: "smbclient" is not installed

apt-get install smbclient


Yes, I already did that, but it’s not having any effect

Could you ever connect to the samba share?

I am able to connect to the share through server.

It’s not recognized as installed on my nextcloud.

What is the output of

dpkg --list|grep 'samba\|smb'

nfrederickx@Ubuntu-1604-xenial-64-minimal:~$ dpkg --list|grep ‘samba|smb’

ii libsmbclient:amd64 2:4.3.11+dfsg-0ubuntu0.16.04.1 amd64 shared library for communication with SMB/CIFS servers
ii python-samba 2:4.3.11+dfsg-0ubuntu0.16.04.1 amd64 Python bindings for Samba
ii samba 2:4.3.11+dfsg-0ubuntu0.16.04.1 amd64 SMB/CIFS file, print, and login server for Unix
ii samba-common 2:4.3.11+dfsg-0ubuntu0.16.04.1 all common files used by both the Samba server and client
ii samba-common-bin 2:4.3.11+dfsg-0ubuntu0.16.04.1 amd64 Samba common files used by both the server and the client
ii samba-dsdb-modules 2:4.3.11+dfsg-0ubuntu0.16.04.1 amd64 Samba Directory Services Database
ii samba-libs:amd64 2:4.3.11+dfsg-0ubuntu0.16.04.1 amd64 Samba core libraries
ii samba-vfs-modules 2:4.3.11+dfsg-0ubuntu0.16.04.1 amd64 Samba Virtual FileSystem plugins
ii smbclient 2:4.3.11+dfsg-0ubuntu0.16.04.1 amd64 command-line SMB/CIFS clients for Unix

Strange, exactly the same packages as i have installed and i my case it’s working well.

Maybe a firewall issue?

Yes I checked, but it also doesn’t work when I turn off the firewall.

Did you threw an eye on the old forum already?


I got it working after trying many things on the link you send me.

It did not seem to work, until I did a restart.

So now everything is going well.

Thanks for helping me!!

and what exactly solved your problem now? I have the same problem right now

It’s is quite embarrassing. I had referred my domain name to a different server that was also running Nextcloud. On that server I had not installed the smbclient. So it was my own stupidity, really.

Hope you find a solution!

If you follow my instructions here the problem should be solved. (i hope so)

1 Like

this old thread ends with “with php7 it’s solved” … I have (only) php7 and this problem, so sorry I need to say, but that php7 solved this is simply not true :wink:

Firewall I’ve already disabled for testing.

apt-get install php-smbclient
helped me, too.

Hi, did you know witch command to install in Freenas 10, has tested with apt-get install w/o success.
Thanks for helping.

Hate to hijack, but do I have to connect a monitor and keyboard to enter apt-get install php-smbclient? I have tried ssh to shell into the Nextcloud Box, but it is asking for credentials and none of the credentials I set up works, neither does the ubuntu:ubuntu or the new ubuntu password I set work. I would like if at all possible to be able to add apps without having to hook up a keyboard and monitor.

I am having the same issue, is anyone using the snap or have you done a manual install of Nextcloud?
I think maybe the issue is that smb does not work with the snap?

You are using a different version of Nextcloud, a different platform. If the proposed solution here doesn’t work, it is very likely that your problem is different as well.

Closing this topic (issue solved, NC version not supported any more).