Tutorial - Cannot get draw.io add-on to work

I want to use the draw.io GUI hosted on my Nextcloud / Server, I read through the Github Readme, but I can’t get it to work.

What I’ve tried

  1. I installed the draw.io add-on from the appstore, using NC 12.0, and activated it.
  2. I set the link in Settings/Additional Settings to something like “https://cloud.foo.com/apps/draw”, however going to this URL redirects me to “https://cloud.foo.com/apps/files” (=homescreen).
  3. I thought that I used it wrong, so I copied an XML-file created with draw.io to my Nextcloud. In Files, I see that it is linked to Drawio:

But when I click on it, it only creates a double header bar (=a graphic bug) in my Nextcloud-flies window:

The URL shows “https://cloud.foo.com/apps/drawio/27356”. So something is going on. However, the URL is “…/drawio/” instead of my specified “…/draw/” - so this may be related.

  1. I thought that this is caused by me using NC12 instead of NC13, so I upgraded. But this issues are still there…

I tested both in up-to-date Firefox as well as Chromium.

Can somebody tell me what I’m doing wrong ?

This is probably a noob question, but maybe somebody else will have the same problem.


I had the same problem with NC 18.04,I fixed it by putting the URL “https://www.draw.io”, it’s probably not using my server instance of draw.io but it works. There may be a security drawback.

Hope this helps.