Turnkey LXC NC container 8MB upload file limit

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 28.0.3
Operating system and version (eg, Ubuntu 20.04): Debian 12
Apache or nginx version (eg, Apache 2.4.25): 2.4.57
PHP version (eg, 7.4): 8.2.7

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):Y

Hi I am new and I do not know how to use this editor, anyway…

My Nexcloude LXC container is Turnkey linux and I am locked with 8MB size of upload files. One weird thing what I found is php.ini in two locations.
Configuration File (php.ini) Path => /etc/php/8.2/cli
Loaded Configuration File => /etc/php/8.2/cli/php.ini

and second
in /etc/php/8.2/apache2/php.ini

All changes from apache2 path are visible in NC system and maybe this is the problem?

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:



Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

TypeError OCA\DAV\Connector\Sabre\Directory::__construct(): Argument #2 ($info) must be of type OCP\Files\FileInfo, bool given, called in /var/www/nextcloud/apps/dav/lib/Upload/UploadHome.php on line 93

This is the php configuration when you run a php script from command line interface (cli). This applies e.g. for the occ command or the updater if run from terminal.

and this one is for the apache php module. This is used for the web-interface provided by apache and the apache php module.

So for the upload one, you need to change apache’s php.ini.

Thanks. In my settings main user folder belongs to root but folders inside belongs to www-data. When I changed main user folder owner to www-data 8MB problem disapeard and now is OK. Weird but OK ;-).