Trying to CalDAV on IPad

I am trying to sync CalDAV to an iPad. I looked at the manual and several forum topics, but to no avail. I tried device specific PW and general PW. One thing I notice on the iPad that it chooses port 0 for SSL. Unsure if that means it will auto-configure of some sort. But in any case I tried several different ports (443, 8443, 9443) to no avail.

iPad 7th gen
iPad version 14.8

NC 22.2
NC calendar 2.3.4

This works out of the box since many years.

Please see

Any specialities of your setup?

Yes, that site I meant when referring to the manual. I have followed it to the dot. (As a side note, I feel it is not entirely clearly written, as there are different types of passwords and it makes no mention which one to use in this case.)

But no, I don’t think I have anything special. It is a self-hosted server installed by Hansson IT using the VM script. The only thing I can think of, is the iPad language setting is Japanese and the NC installation was done in English, but I would be very surprised if that was the issue.

Ok, if you choose SSL with Port 443 (for sure port forwarding needs to be setup) and it is not working what is the error message on iOS?

FWIW, the Nextcloud app works fine on the same iPad with the device specific password. Port forwarding is set-up and the Let’s encrypt cert is valid.

The user name has a space, but I do not think this is the problem? It is 2021 after all.

When following the guide I get an SSL error (Message: “SSL can not connect”) and it offers to turn SSL off. I tried all the various links that Nextcloud offers me to no avail. There is a link that has ?export at the end and that does work as read-only calendar.

I tried the same link that has the ?export at the end for setting up an account and then briefly ticks appear, which lead me to believe that it worked, but again, the calendar would not sync.

i tried the mobileconfig profile file, which imported ok, and the calendar name showed in the calendar app, but it would not sync.

I am still unsure which password to use. Do I have to make a new app specific one?

But this could indeed be the cause of the issue, whether it is 2021 or not :wink:

Wow, and everyone tells me Apple products are easy to use. :roll_eyes: I will look into this. FWIW, I also had already tried substituting the space with %20. Which also did not work.

Edit: Looks like Nextcloud is also not helping the matter: Allowed characters in userids · Issue #21313 · nextcloud/server · GitHub

Yep, that was it. :dizzy_face: