Trusted Domain Error with other domain than in config/config.php

Hello everyone

I’m getting a “Trusted Domain Error” with a domain that is no longer in my nextcloud config.php. :pensive:

I wanted to add a trusted domain, but made an error doing so (I’m using dyn dns and there this is relatively complex for me as a beginner). This led to an Internal Server Error. I undid my changes, but the error remained.
In the Nextcloud logs I get “Trusted domain error. \“46.224.*.*\” tried to access using “xxx.ddns.net” as host.” although I don’t have “xxx.ddns.net” in my config.php anymore. :thinking: (I have restarted the service and rebooted the system as well).
Where else can there be a misconfiguration?
Where could the old domain still be stored?
Where do I still have to make the change?

Sorry if the error is obvious. :dizzy_face: I have not found a forum post describing a similar problem that could help me.
Thanks for your help. :smiley:

Nextcloud Version: 24.0.0
OS: Debian GNU/Linux 11 (bullseye)
[nextclouddirectory]/config/config.php:
[…]
‘trusted_domains’ =>
array (
0 => ‘localhost’,
//0 => ‘server01.local’,
//0 => ‘192.168.1.190’,
),
[…]
‘overwrite.cli.url’ => ‘http://server01.local’, // is the error here? :thinking:
[…]

nextcloud.log (Nextcloud file logging on DEBUG):

{
“reqId”:“xxx”
[…]
“remoteAddr”:“46.224.*.*”,
“user”:"–",
“app”:“core”,
“method”:“GET”,
“url”:"/cron.php",
“message”:“Trusted domain error. \“46.224.*.*\” tried to access using “xxx.ddns.net” as host.”,
“userAgent”: “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:100.0) Gecko/20100101 Firefox/100.0”, “version”: “24.0.0.12”
}

(I’m I am accessing the server from my own network. But from outside I get the same error.)