Trouble connecting nextcloud calander to ios calander app

I have tried the steps outlined in this post NextCloud / MacOS / CalDav / Woes - #24 by neilbaldwin

but I still get either the “CalDAV account verification failed” error or the “Cannot Connect Using SSL” error

I am on ios 16.1.2 and Nextcloud AIO v4.3.4 / Nextcloud Hub 3 (25.0.3) (not sure which is the important one, but it says I am up to date on February 21 2023).

I am running on a linode server, All I did was set up the marketplace app for Nextcloud on it. So it is running all the defaults on that. ubuntu 22.04, its a nanode 1Gb. Don’t know if that’s helpful but I’m very new to all this.

The url for my instance has https in it so I assume it’s all encrypted, I read in another post that after ios 12 you needed that for it to work. I also check by adding .well-known/caldav to the end of my instance url and I think it is working since it brought me to the page that said “This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client.”

I have no idea what port ssl is running on (or even what that really means or how to change that) but from what I read the defualt is usually 443 so I assume I’m on that. I tried running “ss -ta” on the Weblish console for my linode and I’m not really sure what I’m looking at or if that’s even how you’d check that. it looks like this
so maybe I need to be using 8443? I tried that and it didn’t change anything

what’s super weird is that I swear it was working a few days ago before I updated nextcloud. But then the calendar app started asking me to put in the password again (I think maybe because I had changed my icloud email or something) and it wouldn’t authenticate. So I removed it and tried re-adding it and now it gives me these errors.

Any Idea’s? I thought I tried all the suggestions from previous posts, but maybe I missed something? To me it’s weird that it was working and now isn’t, so maybe the new update did something?

I figured it out, it was because I added 2FA. The way I got it to work was by following these steps