Troube with Collabora wopi-allowlist in Nextcloud AIO behind Cloudflare tunnel

I’m having trouble with Collabora office setup. I set up the Nextcloud AIO behind Cloudflare tunnel and cannot open any documents with Collabora. The Github guide for Nextcloud AIO suggests the following:

It is known that the in AIO included collabora (Nextcloud Office) does not work out of the box behind Cloudflare. To make it work, you need to add all Cloudflare IP-ranges to the wopi-allowlist in

However I’m not able to find this wopi-allowlist in my Nextcloud Collabora (richdocuments) settings. Am I missing something or is the guide outdated?

I tried looking for a config file for this but wasn’t able find one.

same problem here. no solution yet

Administration settings–>Office (also known as

It’s labeled Allow list for WOPI requests.

1 Like

Thanks Josh - I found it after a few hours of digging :))
The “also known” is not obvious…Maybe worth clarifying in the documentation.

1 Like

I had set up a Cloudflare access authentication page in front of my Nextcloud instance that was blocking access to Collabora. I removed it and now everything works great. I am also marking Josh’s answer as a solution as it has resolved the issue for another user.