Tried to upgrade php intl and now Nexcloud fails to start

For anyone looking at this or giving me any help on this first of let me say thank you.

Nextcloud version: 19.08
Operating system and version: Ubuntu 18.04
Apache version: Apache/2.4.29
PHP version: not really sure. Either 7.2 or 7.4. It was working with 7.2 before

I have an Ubuntu 18.04 install that was running Nexcloud 19.08. I think 19.08 is still installed but the sight is not running.

Every time I have upgraded Nexcould has stated I need to update PHP. I have run the commands at the command line and it shows PHP 7.4 but Nextcloud still shows I am using PHP 7.2. I am not sure if this matters but I thought I would mention it.

I was looking at a log file and noticed an error.

" [ERROR:you are using a fallback implementation of the intl extension]

I saw this link and followed the Linux instructions on how to install and enable intl.

I ran the commands for 7.2 and 7.4.

the apt install had me update my PHP files to current versions. Once I restarted apache2 my site just comes up with the following text. (no formatting)

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

I have looked at my /var/www/nextcloud/config/config.php and found that I have the log file pointing to /var/log/nextcloud/nextcloud.log.

I have run a tail -f /var/log/nextcloud/nextcloud.log | jq but the info does not make sense to me. It seems to be looping over and over and nothing looks really wrong except for one line that states

“File”: “/var/www/nextcloud/lib/private/Memcache/Factory.php”,
“Line”: 98,
“Hint”: “Is the matching PHP module installed and enabled?”,
“CustomMessage”: “–”

Line 98 of that file states

throw new \OC\HintException(strtr($missingCacheMessage, [

Here is the output of my php -v from the command line

PHP 7.4.15 (cli) (built: Feb 14 2021 14:19:46) ( NTS )
Copyright © The PHP Group
Zend Engine v3.4.0, Copyright © Zend Technologies
with Zend OPcache v7.4.15, Copyright ©, by Zend Technologies

I am not really a PHP person but I found this command and It shows two versions.

phpquery -V
7.4
7.2

here is my /var/www/nextcloud/config/config.php

<?php $CONFIG = array ( 'passwordsalt' => 'removed for security reasons', 'secret' => 'removed for security reasons', 'trusted_domains' => array ( 0 => 'localhost', 1 => 'nextcoud', 2 => '192.168.0.60', 3 => 'removed for security reasons', ), 'datadirectory' => '/mnt/ncdata', 'dbtype' => 'pgsql', 'version' => '19.0.8.1', 'overwrite.cli.url' => 'http://localhost', 'dbname' => 'nextcloud_db', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'dbuser' => 'ncadmin', 'dbpassword' => 'removed for security reasons', 'installed' => true, 'instanceid' => 'ocytt4b5wcj0', 'log_type' => 'file', 'logfile' => '/var/log/nextcloud/nextcloud.log', 'loglevel' => '2', 'mail_smtpmode' => 'smtp', 'remember_login_cookie_lifetime' => '1800', 'log_rotate_size' => '10485760', 'trashbin_retention_obligation' => 'auto, 180', 'versions_retention_obligation' => 'auto, 365', 'simpleSignUpLink.shown' => 'false', 'memcache.local' => '\\OC\\Memcache\\APCu', 'filelocking.enabled' => true, 'memcache.distributed' => '\\OC\\Memcache\\Redis', 'memcache.locking' => '\\OC\\Memcache\\Redis', 'redis' => array ( 'host' => '/var/run/redis/redis-server.sock', 'port' => 0, 'timeout' => 0.5, 'dbindex' => 0, 'password' => 'removed for security reasons', ), 'maintenance' => false, 'theme' => '', 'updater.secret' => 'removed for security reasons', ); I have rebooted the server with no change. If anyone could help me know where to look and figure out what is going wrong that would be great.

It looks like this is now fixed. My son came home and with a fresh set of eyes we did not see that any PHP was enabled on apache.

I ran the command

“a2enmod php7.4”

then restarted apache2

and it started correctly and all the data is there and working.

One thing to note is even though I know 7.4 is running the warnings still say the system is running on 7.2.

1 Like