Trashbin not being emptied

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 17.0.3
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): nginx 1.14
PHP version (eg, 7.1):7.2

The issue you are facing:
Trashbin ist not being emptied e.g. after 8 days.

Setting is: trashbin_retention_obligation’ => ‘7, 8’,

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. group folders are used
  2. a retention policy moves the files to the trashbin. this works great
  3. Items in trashbin are now 11 days old, but the trashbin policy in the config.php ist set to min age 7 and max age 8

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'passwordsalt' => 'removed',
  'secret' => 'removed',
  'trusted_domains' =>
  array (
    1 => 'servername',
    2 => '',
  'datadirectory' => '/opt/data',
  'tempdirectory' => '/opt/data/upload-temp',
  'dbtype' => 'pgsql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'somedb',
  'dbhost' => 'localhost:5432',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'ncdb',
  'dbpassword' => 'removed',
  'installed' => true,
  'instanceid' => 'removed',
  'maintenance' => false,
  'default_language' => 'de',
  'default_locale' => 'de_DE',
  'session_lifetime' => 900,
  'remember_login_cookie_lifetime' => 0,
  'session_keepalive' => false,
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpdebug' => true,
  'enable_previews' => false,
  'overwriteprotocol' => 'https',
  'trashbin_retention_obligation' => '7, 8',
  'loglevel' => 2,
  'logdateformat' => 'F d, Y H:i:s',
  'logfilemode' => 416,
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  '' => true,
  'sharing.minSearchStringLength' => 3,
  'upgrade.disable-web' => false,
  'simpleSignUpLink.shown' => false,
  'mail_from_address' => 'no_reply',
  'mail_domain' => '',
  'mail_smtphost' => '',
  'mail_smtpport' => '25',
  'filelocking.enabled' => 'true',
  'config_is_read_only' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '',
    'port' => 6379,
    'timeout' => 0.0,
  '' => 'stable',
  'updater.secret' => 'removed',

The output of your Apache/nginx/system log in `/var/log/____`:



this is a thread talking about the behavior and the issue. groupfolders do not get emptied by the retention policy

This is the tickets about the problem

And a workaround which I do not like much because I think it breaks stuff, but I am not the super expert on this :smiley:

If you can just give some feedback to the first issue to raise awareness.