Trash bin automatically cleared for one user

Nextcloud version (eg, 10.0.2): 11.0.4
Operating system and version (eg, Ubuntu 16.04): openSUSE leap42.2
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4…(don’t really know version for the moment.)
PHP version (eg, 5.6): 5.6
Is this the first time you’ve seen this error?:

Can you reliably replicate it? (If so, please outline steps):
Delete a file. Open trash bin and find the deleted file. Wait some time, open trash bin and find the trash bin is empty.

The issue you are facing:
Trash bin is automatically cleared for one account. Other accounts are not affected.

The output of your Nextcloud log in Admin > Logging:
Nothing from when this happens.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):
Not possible to fetch at this point in time.

The output of your Apache/nginx/system log in /var/log/____:
Not possible to fetch at this point in time.

Remember, this information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart: Feel free to use a pastebin service, otherwise log files can be indented with 4 spaces on each line to present them in a friendlier way on the forum.

It’s difficult without more information about quota and used space (%) of the account as well as the setting 'trashbin_retention_obligation' from the config.php file. :wink:

How long?

Here is my config.php:
<?php $CONFIG = array (
‘instanceid’ => ‘xyz’,
‘passwordsalt’ => ‘xyz’,
‘secret’ => ‘xyz6’,
‘trusted_domains’ =>
array (
0 => ‘abc’,
1 => ‘def’,
2 => ‘ghi’,
3 => ‘jkl’,
‘datadirectory’ => ‘abc’,
‘overwrite.cli.url’ => ‘abc’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘’,
‘dbname’ => ‘owncloud’,
‘dbhost’ => ‘localhost’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘owncloud’,
‘dbpassword’ => ‘xyz’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
‘loglevel’ => 2,
‘maintenance’ => false,
‘updatechecker’ => false,
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘theme’ => ‘’,
‘mail_from_address’ => ‘abc’,
‘mail_smtpmode’ => ‘smtp’,
‘mail_domain’ => ‘’,
‘mail_smtpsecure’ => ‘ssl’,
‘mail_smtphost’ => ‘’,
‘mail_smtpauth’ => 1,
‘mail_smtpport’ => ‘465’,
‘mail_smtpname’ => ‘abc’,
‘mail_smtppassword’ => ‘xyz’,
‘’ => ‘stable’,

A few weeks back I enable a cronjob to run cron.php every 15 and that one has something to do with the problem. I disable that job and then the trash bin is not cleared any longer. If I reenable that job then the trash bin is cleared, every 15 minutes it seems…

I use about 40% of the quota.

But why is only one account showing this problem? What can I have done to configure it like that?

Some more information I now have.

It seems that quota is in the focus here. The account with the the issue had a qouta of 40 GB and used 17 GB. But, there were also files and folders shared with this account which put the total amount of data to 42 GB.

If I set the quota to more than 42 GB, e.g. 50, the trash bin is not cleared automatically. Resetting the quota to 40 GB again and the trash bin is automatically cleared.

To me this feels like a bug in the cron process. I mean, if someone shares a lot of files with another user that users trash is automatically cleared. Not good if any files should be restored.

Cron uses the default config settings.
Try to modify the handling of the trash bin. The default setting is:

'trashbin_retention_obligation' => 'auto',

Set it to disabled and check again.

I have set it to ‘disabled’ and set quota to 40 GB again.
Total number of files and folders, including shares: 42 GB
Trash bin has not been cleared.

I wouldn’t say that this is a solution though as it is set to ‘auto’ as default.

jump onto this as well, seems not to work as expected