Transfert du ncdata sur disque dur ensuite erreur

J’ai installaler nextcloud sur un raspberry pi 4 8gb et le tout a bien été mais la j’ai fait la commande ncdatadir et la depuis ce temps la je ne peux plus rien faire j’ai un nextcloud check error. Et aussi je ne comprend pas pourquoi mon système en mode terminal me répond je pense en espagnole. ???

Run

sudo ncp-report

and share output in txt file or via link to a pastebin service

can try

sudo raspi-config

and set the language/locales or run

sudo dpkg-reconfigure locales

and select your language

I can read and understand French, but not write in French, sorry.

1 Like

@Normandstm apres le transfert, les permissions des répertoires parents et du répertoire concerné sont elles correctes ? ( RWX pour www-data , je ne suis pas sur de l’utilisateur ).

ces impossible je voir les permissions j’ai meme pas access a la commande ls -l dans le terminal

Thank you, I have been able to go back in english and french.

{“reqId”:“10TKHkIoUSG1816iWdl1”,“level”:2,“time”:“2021-04-11T19:48:16+00:00”,“remoteAddr”:"",“user”:"–",“app”:“no app in context”,“method”:"",“url”:"–",“message”:“Temporary directory /media/mondisquecloud/ncdata/tmp is not present or writable”,“userAgent”:"–",“version”:“20.0.2.2”}
{“reqId”:“10TKHkIoUSG1816iWdl1”,“level”:3,“time”:“2021-04-11T19:48:17+00:00”,“remoteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"",“url”:"–",“message”:{“Exception”:“Error”,“Message”:“fopen(/media/mondisquecloud/ncdata/data_dir_writability_test_6073528161e9a.tmp): failed to open stream: Permission denied at /var/www/nextcloud/lib/private/legacy/OC_Util.php#804”,“Code”:0,“Trace”:[{“function”:“onError”,“class”:“OC\Log\ErrorHandler”,“type”:"::",“args”:[2,“fopen(/media/mondisquecloud/ncdata/data_dir_writability_test_6073528161e9a.tmp): failed to open stream: Permission denied”,"/var/www/nextcloud/lib/private/legacy/OC_Util.php",804,{“config”:{“class”:“OC\SystemConfig”},“l”:{“class”:“OC\L10N\LazyL10N”},“errors”:[{“error”:“Your data directory is invalid”,“hint”:“Ensure there is a file called “.ocdata” in the root of the data directory.”}],“CONFIG_DATADIRECTORY”:"/media/mondisquecloud/ncdata",“webServerRestart”:false,“setup”:{“class”:“OC\Setup”},“urlGenerator”:{“class”:“OC\URLGenerator”},“availableDatabases”:{“mysql”:“MySQL/MariaDB”},“testFile”:"/media/mondisquecloud/ncdata/data_dir_writability_test_6073528161e9a.tmp"}]},{“file”:"/var/www/nextcloud/lib/private/legacy/OC_Util.php",“line”:804,“function”:“fopen”,“args”:["/media/mondisquecloud/ncdata/data_dir_writability_test_6073528161e9a.tmp",“w”]},{“file”:"/var/www/nextcloud/lib/private/Console/Application.php",“line”:161,“function”:“checkServer”,“class”:“OC_Util”,“type”:"::",“args”:[{“class”:“OC\SystemConfig”}]},{“file”:"/var/www/nextcloud/console.php",“line”:99,“function”:“loadCommands”,“class”:“OC\Console\Application”,“type”:"->",“args”:[{“class”:“Symfony\Component\Console\Input\ArgvInput”},{“class”:“Symfony\Component\Console\Output\ConsoleOutput”}]},{“file”:"/var/www/nextcloud/occ",“line”:11,“args”:["/var/www/nextcloud/console.php"],“function”:“require_once”}],“File”:"/var/www/nextcloud/lib/private/Log/ErrorHandler.php",“Line”:91,“CustomMessage”:"–"},“userAgent”:"–",“version”:“20.0.2.2”}
{“reqId”:“10TKHkIoUSG1816iWdl1”,“level”:3,“time”:“2021-04-11T19:48:17+00:00”,“remoteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"",“url”:"–",“message”:“fopen(/media/mondisquecloud/ncdata/nextcloud.log): failed to open stream: Permission denied at /var/www/nextcloud/lib/private/Log/File.php#85”,“userAgent”:"–",“version”:“20.0.2.2”}
{“reqId”:“We29GrJz4m3CjtpYHigE”,“level”:2,“time”:“2021-04-11T19:48:21+00:00”,“remoteAddr”:"",“user”:"–",“app”:“no app in context”,“method”:"",“url”:"–",“message”:“Temporary directory /media/mondisquecloud/ncdata/tmp is not present or writable”,“userAgent”:"–",“version”:“20.0.2.2”}
{“reqId”:“We29GrJz4m3CjtpYHigE”,“level”:3,“time”:“2021-04-11T19:48:21+00:00”,“remoteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"",“url”:"–",“message”:{“Exception”:“Error”,“Message”:“fopen(/media/mondisquecloud/ncdata/data_dir_writability_test_60735285ceccb.tmp): failed to open stream: Permission denied at /var/www/nextcloud/lib/private/legacy/OC_Util.php#804”,“Code”:0,“Trace”:[{“function”:“onError”,“class”:“OC\Log\ErrorHandler”,“type”:"::",“args”:[2,“fopen(/media/mondisquecloud/ncdata/data_dir_writability_test_60735285ceccb.tmp): failed to open stream: Permission denied”,"/var/www/nextcloud/lib/private/legacy/OC_Util.php",804,{“config”:{“class”:“OC\SystemConfig”},“l”:{“class”:“OC\L10N\LazyL10N”},“errors”:[{“error”:“Your data directory is invalid”,“hint”:“Ensure there is a file called “.ocdata” in the root of the data directory.”}],“CONFIG_DATADIRECTORY”:"/media/mondisquecloud/ncdata",“webServerRestart”:false,“setup”:{“class”:“OC\Setup”},“urlGenerator”:{“class”:“OC\URLGenerator”},“availableDatabases”:{“mysql”:“MySQL/MariaDB”},“testFile”:"/media/mondisquecloud/ncdata/data_dir_writability_test_60735285ceccb.tmp"}]},{“file”:"/var/www/nextcloud/lib/private/legacy/OC_Util.php",“line”:804,“function”:“fopen”,“args”:["/media/mondisquecloud/ncdata/data_dir_writability_test_60735285ceccb.tmp",“w”]},{“file”:"/var/www/nextcloud/lib/private/Console/Application.php",“line”:161,“function”:“checkServer”,“class”:“OC_Util”,“type”:"::",“args”:[{“class”:“OC\SystemConfig”}]},{“file”:"/var/www/nextcloud/console.php",“line”:99,“function”:“loadCommands”,“class”:“OC\Console\Application”,“type”:"->",“args”:[{“class”:“Symfony\Component\Console\Input\ArgvInput”},{“class”:“Symfony\Component\Console\Output\ConsoleOutput”}]},{“file”:"/var/www/nextcloud/occ",“line”:11,“args”:["/var/www/nextcloud/console.php"],“function”:“require_once”}],“File”:"/var/www/nextcloud/lib/private/Log/ErrorHandler.php",“Line”:91,“CustomMessage”:"–"},“userAgent”:"–",“version”:“20.0.2.2”}
{“reqId”:“We29GrJz4m3CjtpYHigE”,“level”:3,“time”:“2021-04-11T19:48:21+00:00”,“remoteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"",“url”:"–",“message”:“fopen(/media/mondisquecloud/ncdata/nextcloud.log): failed to open stream: Permission denied at /var/www/nextcloud/lib/private/Log/File.php#85”,“userAgent”:"–",“version”:“20.0.2.2”}
tail: no s’ha pogut obrir ‘/media/mondisquecloud/ncdata/nextcloud.log’ per a llegir: El fitxer o directori no existeix

lorsque je fait http://localhost/nextcloud

j’ai l’erreur

Votre répertoire n’est pas valide Assurez-vous que le répertoire de données contient un fichier “.ocdata” à sa racine. Your data directory is not writable Le problème de permissions peut généralement être résolu en donnant au serveur web un accès en écriture au répertoire racine. Voir https://docs.nextcloud.com/server/20/go.php?to=admin-dir_permissions.

ha ok merci j’ai trouvé qu’il me faut me déplacer a la racine en premier et mon ls fonctionne et j’ai pu changé les permissions de mon répertoire pour 777 et la j’ai besoin de savoir ou prenfer mon fichier .ocdata qu’il ne parviens pas a trouver

where can I find .ocdata it doesn’t find it.

@Normandstm normalment il devrait être dans le repertoire ( à la racine) qui contient toutes les données ( ls -la pour le voir) sinon essayé de créer un fichier .ocdata ( il n’y a rien dedans ) et donnez lui les bonnes permissions.

ok super ca ces fait merci. Maintenant il me dit

Your data directory is not writable Le problème de permissions peut généralement être résolu en donnant au serveur web un accès en écriture au répertoire racine.

ou et comment je fait ca.

@Normandstm Quel utilisateur a actuellement les droits sur votre repertoire nextcloud ?
qu’en ai t-il pour les répertoires parents, www-data a t-il les droit en lecture sur les différent répertoire plus haut que celui de vos données ?
pour /media/mondisquecloud/ncdata/, l’utilisateur www-data a t-il toutes les permissions (RWX) ?

la seul place que je peux aller est dans le nextcloudpi panel.

si J’essaie avec utilisateur http://localhost/nextcloud. je ne viens meme pas a bout de rentrer dedans et les deux utilisateur je crois sont ncp

@Normandstm
j’ai oublié de préciser , il faut utiliser le terminal de votre machine avec l’utilisateur root
utilisez la commande ls -l pour voir qu’elle utilisateur a les droit sur vos dossier et fichiers

ok si je vais au root / et que je fais ls -l tout est root

@Normandstm maintenant aller dans /media/mondisquecloud/ toujours en tant que root et donnez moi la sortie qui vous est donnée pour ncdata avec ls -l
ne changer aucune permissions pour les dossier et fichier dans /

mysql et root pour un nom du fichier debian-10.3.flag

qu’elles sont les permissions ?? ( drwx- ??? )

pi@nextcloudpi:/media/mondisquecloud $ ls -l ncdata
total 155704
-rw-rw---- 1 mysql mysql 16384 avr 11 20:50 aria_log.00000001
-rw-rw---- 1 mysql mysql 52 avr 11 20:50 aria_log_control
-rw-r–r-- 1 root root 0 avr 11 06:09 debian-10.3.flag
-rw-rw---- 1 mysql mysql 4319 avr 11 20:50 ib_buffer_pool
-rw-rw---- 1 mysql mysql 79691776 avr 11 21:34 ibdata1
-rw-rw---- 1 mysql mysql 33554432 avr 11 21:34 ib_logfile0
-rw-rw---- 1 mysql mysql 33554432 nov 27 22:55 ib_logfile1
-rw-rw---- 1 mysql mysql 12582912 avr 11 20:51 ibtmp1
-rw-rw---- 1 mysql mysql 0 nov 27 22:55 multi-master.info
drwx------ 1 mysql mysql 2708 avr 11 06:09 mysql
-rw-rw---- 1 mysql mysql 16 avr 11 06:09 mysql_upgrade_info
drwx------ 1 mysql mysql 6564 avr 11 16:45 nextcloud
drwx------ 1 mysql mysql 12 avr 11 06:09 performance_schema
-rw-rw---- 1 mysql mysql 24576 avr 11 20:51 tc.log

@Normandstm Pourriez vous donner le résultat pour le dossier nextcloud ( qui est dans ncdata) en masquant les nom des utilisateur ( et autre données privée).