TOTP suddenly not working

Hi,

My totp has suddenly stopped working. I haven’t applied any nextcloud(11.0.2) updates for some time. In order to get into my nextcloud instance, I’ve had to resort to:

sudo -u www-data php occ app:disable twofactor_totp

I’ve tried regenerating my TOTP codes, adding the QR code back into my phone and replacing the app. I was hoping someone could tell me where the logs for the TOTP app are? All it says on my home page is:

“Error while validating your second factor”

Hey,

since we recently switched to daylight saving time, maybe either your phone or your server was not adjusted? Did it work when you re-setup the OTP?

I have exact the same problem. SInce this week my TOTP don’t work anymore

Ok, I solved it. The problem was that the time on my mobile phone was 2 minutes before my server. My Linux workstation had the same time as my server. I set my phone to auto update time and immediately the time was the same as my server and TOTP works again :slight_smile:

Thanks guys. I’m running ubuntu server and it appears to have the same local time as my desktop. I’ll have a play around and get back when I can