Total NOOB ONLYOFFICE cannot be reached. Please contact admin


#1

During the ONLYOFFICE setup I used the same domain name as my server. I did not think that was right but did not know otherwise. Install went fine but when I try to create a new document I get ONLYOFFICE cannot be reached. Please contact admin. This is my first time using NextCloud and OnlyOffice, please be gentle…How can I fix?


#2

Logging tab shows:

Undefined index: edit at /var/www/nextcloud/apps/onlyoffice/templates/settings.php#93


#3

I tried to chace the default port to 8443 but get:

Error when trying to connect (Bad healthcheck status)

I think I created a port conflict but not sure how to check, i’m an old Windows guy :slight_smile:


#4

which howto did you follow?

are you sure that you setup the certificates for only office right?


#5

During the setup it asked if I wanted to use the existing cert, I said yes, keep the existing.

The existing is the one generated by the script found here.

https://github.com/nextcloud/vm/blob/master/lets-encrypt/activate-ssl.sh

Thanks


#6

if you use Daniels scripts best to ask him. :wink:

@enoch85


#7

The OnlyOffice scripts has built in SSL so no need to use a seperate script for that.

Also, please use another subdomain that the original, e.g. office.yourdomain.com


#8

So I created another subdomain as suggested but am now geting a different errror:

It’s not a firewall issue as all other features work as expected. I also tried to create a DNS text recored using the above, then rereun the setup script but it seems the acme-challenge is different everytime the scripts runs. Also, I hope everyone enjoyed your Thanksgiving if in the US. Thanks for the help!!!


#9

Take a look at this and this.

Let me know how it works out for you.


#10

Daniel,
I reviewed the videos, while very pretty to watch, they didn’t really help. More context. I purchased your preconfigured Hyper-V VM. I have met a prerequisites that I know of. I entered the 2 different DNS zones, cloud.yourdomain.com and office.yourdomain.com. The install of NextCloud went perfectly, even the upgrade and every other option i selected. but when it came to OnlyOffice, I get the same error on the acme-challenge. Note that everytime I start over I redeploy the downloaded VHDX files. So I should be starting from new.

I noticed a OnlyOffice option in the NextCloud GUI. Is that an option?


#11

Here is where I stand. As DNS is correct, I looked at name resolution in the VM. I saw the host file had my domain pointed to 127.0.0.1. I added an entry with my public address. That got me past my initial error. The onlyoffice scriptes proceeds until it gets to the acme-challenge. During the Nextcloud install I was prompted to create a acme-challenge text record, which I did. That got Nextcloud installed. The onlyoffice script dose not ask me to do this but i created the same recored it in the office.mydomain. I still get:

Failed authorization procedure. office.brickcitysolutions.com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://office.brickcitysolutions.com/.well-known/acme-challenge/hIYBJLHOt7TpJcy1WQNoN4aqapkWSJnuiWA_7JdxWtE: Timeout during connect (likely firewall problem)

IMPORTANT NOTES:

How do i get around this?

Thanks again for the help


#12

@enoch85

Port 80 was closed. Thanks Daniel!


#13

Glad you solved it. Sorry for the late response.

Do you think I should make the notice more clear? https://github.com/nextcloud/vm/blob/master/lets-encrypt/activate-ssl.sh#L29 Please let me know and I’ll fix it!

Thanks!


#14

A small few words, or a link, explaning the process would be helpful as an addtion. Also following up with a question, As a home user getting prot 80 open is an expensive, ongoing action. Would port 80 need to be open all the time, or for just timed operations? ie once a month to check certs, or anything to that effect?

Thanks for all your hard work and Happy New Year!


#15

everything will be redirected to 443.

why is it expensive to open port 80?


#16

@ Reiner_Nippes THis looks like the answer to my problem!! My ISP only allows 80 open to commercial subscribers and the cost is triple what I pay as a residential subscriber.

Now as I stated I am a Windows guy and a Noob at Linux. In the link you provided, should I change the highlighted line 132 or something else? Also what is the path to the file?

Again NOOB! Thanks for the great assist!!!


#17

well.

you need port 80 open from the internet to get a certificate from letsencrypt. (you may google “letsencrypt without port 80”, to find an alternative way to get one.)
you need each three month a new certificate. that’s it.

no need to change anything on nextcloud. in fact you don’t want to change the behavior that your nextcloud can be accessed unencrypted.