Too many redirects NCP nginx proxy manager pi-hole + unbound

Dear All,

Until now I am connecting to my NCP instance only via VPN. As I want to share photos etc with friends, I want to go public.
I want to expose the instance through nginx proxy manager, which I already setup under docker.

Following is my setup

  • pi-hole + unbound as reverse DNS - local DNS points my DuckDNS address to the NextCloudPi instance (RPi-IP).
  • NextCloudPi (v 1.52.0 ) running on RPI4 (I’ve added the nginx proxy manager IP in trusted proxies

nginx PM seems to work. I exposed port 80 and 443 in my router, got my SSL certificate and configured the proxy host accordingly (scheme http → IP nextcloudpi → port 80 - Force SSL, HTTP/2 Support, HSTS enabled.

When I try to reach the duckDNS URL I get an Error - too many redirects.

I read lots of comments regarding wrong cloudflare config with this error message, so I am not sure if NCP or pi-hole does require re-configuration.

I am lost here, I’m afraid and I would be glad if someone could give me a hint.

Is there anyhing else in terms of logs/configs I could provide?
I am happy to do so

thank you

edit: The nextCloudPi Panel mentions the Ports 80 and 443 to be open, when I open them on the router for the nginx proxy manager machine. As the nginx proxy has another IP then NCP, NCP takes at least note of the proxy.

Do you think it is more towards a misconfigured pi-hole and unbound?


issue was double-forcing HTTPS - in nginxPM as well as in NextcloudPi Panel.
After deactivating “Force HTTPS” in NectCloudPi it works.


1 Like