To add a mail account, please contact your administrator

I’m Having Issue with adding mail configuration on any user even admin user, i have removed mail client from apps and add back, still the same issue, as if the option to add email is disabled.
how can i fix this issue?
Nextcloud Version: 27.1.5


you may you check with:

sudo -u www-data php /var/www/nextcloud/occ config:list |grep mail

before and after removing the mail app and make sure that you can see this in the output after installing:

“emailTestSuccessful”: “1”,

After that you might lift the debug level and check what:

sudo -u www-data php /var/www/nextcloud/occ log:watch

is talking.

This might be a path.

i have set it up in docker, I’ve tried the commands but did not work still the same issue

Please give information if you want information. I don’t know what you have done in docker.
Can you sent a test mail to yourself first of all. And what about the log-file and the debug level?

I’m new in all this, you should explain what should i do and how, I’m new to this environment, where should i input this commands? in docker and in which container, thank you for your help.

Because i never used docker before and still learning.

In Administration → Basic Settings → mail server is working properly and sending email, i’m trying to figure out how to get the given commands to work.

It looks like what the master container in docker has been update from 7.9.0 to 7.9.1 I started having this issue.

Ok, no problem. This is not about docker yet. I want to know is your mail-setting in basic-setting giving you a green light after installing?

Yes It’s Showing the green light, and I’m getting email in my mailbox, but thing is as if only the interface has been disabled. I’m going to restore master container back to 7.9.0 to check if it solved the issue, and I’ll let you know the result.

but is there anything else i can check before i restore it back?

Ok, let me know how it workded out.

The next step could be to raise the debug level

sudo -u www-data php occ log:manage --level debug

an read the nextcloud.log while trying again.

sudo -u www-data php /var/www/nextcloud/occ log:watch

As asked before :wink:

There is a webbased occ in case you have no terminal.

The commands that you have listed are not working, I’m getting the following error. can you please point out what I’m doing wrong?

occ command

Ok :slight_smile:

occ log:manage --level debug

If this don’t work please check the manual first.

it did not work i just input

log:manage --level debug

and i got the following output

occ command

I received mail app update and still the same issue.

where can i find the log files?


see the path wtih

occ log:file

or use, like already written here… :wink:

occ log:watch

While reproducing it in another window.

The command:
occ log:tail

Reads the log without following it.

I found the cause of the issue and solved it by enabling Administration settings-> Administration-> Groupware (Allow additional Mail accounts from User Settings) option.