TLS connection in localarea with "Nextcloud Note"

I have nextcloud running on a local raspberrypi and TLS with nginx proxy.
I have certificates installed for windows and iso, and I can view each from a web browser,
But from “Nextcloud Note” on IOS, I get the following log and cannot access. - - [01/Apr/2024:07:36:04 +0900] “POST /index.php/login/flow HTTP/1.1” 303 0 “-” “Mozilla/5.0 (iOS) NextcloudNotes/4.2.0” - hoo [01/Apr/2024:07:36:04 +0900] “GET /status.php HTTP/1.1” 200 170 “-” “Nextcloud Notes/4.2.0 (com.peterandlinda.iOCNotes; build:0; iOS 17.3.1) Alamofire/5.6.4” - hoo [01/Apr/2024:07:36:05 +0900] “GET /ocs/v1.php/cloud/capabilities HTTP/1.1” 200 1282 “-” “Mozilla/5.0 (iOS) NextcloudNotes/4.2.0” - hoo [01/Apr/2024:07:36:05 +0900] “GET /apps/notes/api/v1/settings HTTP/1.1” 404 241 “-” “Nextcloud Notes/4.2.0 (com.peterandlinda.iOCNotes; build:0; iOS 17.3.1) Alamofire/5.6.4” - hoo [01/Apr/2024:07:36:05 +0900] “GET /index.php/apps/notes/api/v1/settings HTTP/1.1” 200 82 “-” “Nextcloud Notes/4.2.0 (com.peterandlinda.iOCNotes; build:0; iOS 17.3.1) Alamofire/5.6.4” - hoo [01/Apr/2024:07:36:51 +0900] “GET /index.php/apps/notes/api/v1/notes HTTP/1.1” 499 0 “-” “Nextcloud Notes/4.2.0 (com.peterandlinda.iOCNotes; build:0; iOS 17.3.1) Alamofire/5.6.4”

Is it not possible to use TLS from the local area?
Thank you in advance.

Using the local IP on the desktop computer works? Just the iPhone? And the iPhone outside your local network works? You access everything through your nginx proxy (local connections as well)?

If you access from local, do you use the hostname (and the local DNS resolver gives you the local ip from your Nextcloud)? Or do you just use the IP address?

your nginx proxy or the webserver for Nextcloud?

Thank you for replying. As you mentioned, my local network does not have DNS. I am using avahi-daemon and was able to view it from my browser. I have also confirmed the transition and completion of the initial authentication screen from the “Nextcloud Notes” configuration, It appears that the synchronization process is failing in operation. This may not be a tls problem, but rather a local network name resolution problem in “Nextcloud Notes”.

I am operating with a server certificate signed by a self-signed certificate that I use as a private Certificate Authority in the local area.
I have confirmed that I can browse on both Windows and IOS, and also confirmed on the global IP host as well.
Today, I tried to configure “Nextcloud Notes” on the host operating on a global IP,
However, I got stuck at “Allow access” and could not proceed.
Does “Nextcloud Notes” on IOS fail to validate a server certificate signed with a self-signed certificate?

I changed raspberrypi3 to raspberrypi4 and it worked.
On raspberrypi3, the sync seemed to time out.
Can I change the timeout period?
NextcloudNotes is a very important tool and its volume increases every day.
Thank you very much.