"Timeout while trying to connect to Nextcloud at https://..."


This is from a Macbook pro running Catalina with all updates.

I just installed the Nextcloud client version 2.6.1. I have been able to connect to my cloud provider from two different CentOS boxes (but they run a much older version of the client software). One of these boxes is in the same office, although on a different subnet.

I cannot connect to the cloud service from the connection wizard. I get “Timeout while trying to connect to Nextcloud at https://xxx.xxx.xx/status.php”. However, I can access that exact address from my web browser on the mac - it spits out a text string with some info about the server.

Really confused here!

I had the same problem with client 2.6.1 on a Linux system. The problem disappeared after some time, but the reason stays unclear. Is this still an issue for you? Maybe it was caused by slow internet connectivity, because my email client also behaved strange at that time.

Nope; I am on a university connection and from my Linux box get 50 MB/s throughput.

Yes, this is an issue for me, as of this morning, and I am a new user of Nextcloud. I tried earlier version of the client as well as a recent beta version with the same result. It’s as if it’s being blocked by a firewall - perhaps it is. But I have no firewall running on my mac and the machine 2 feet away is able to connect, so I am at a loss here.

Following up, I hooked up my mac to another provider (tethered via WIFI to my phone) and got the same timeout - hence it seems to me to not be a firewall issue, rather, it is an issue with Catalina.

I would ask therefore, has anyone else been able to connect to a Nextcloud https server with MacOS Catalina? A whole lot of extra security stuff comes with that release, and perhaps something is being silently blocked at the OS level.

OK, I tried a different cloud provider and after being asked to verify some things with my browser, I was able to connect. So perhaps it an issue specific to the cloud provider I am using.