Time bug external storages

Good afternoon.
I am using Nextcloud 22.2.3 and Samba 4.13.13-Debian (as a Samba domain member). Samba network balloon is connected in nc. When I create a new file, it has a time of +3 hours. What setting am i missing ?

Check the systems times of your Nextcloud and Samba server and make sure that they are both set to the same time zone.

How set time zone in NC and samba? Files have correct datetime, wrong only in nextcloud https and webdav

The web server usually takes the time from the underlying system, but the PHP configuration might influence the result. Check the “date.timezone” setting (e.g. date.timezone = "Europe/Berlin"), described in the Administraor Guide. Finally the individually set country schema (Settings > Personal information) might also influence the time being displayed/used.

Yes. This set
I connect samba and take this problem, when i connect to Synology samba - the problem does not arise

In this case check the time setting on the Samba server which is not working.