This forum is EXTREMELY slow

It is just a very slow server, I really think they do not want the community to use it :wink:
For me, TTFB (time for first byte) = 50 seconds for a simple 1.4kb PNG (not even a script)!

It’s really just a matter of putting a load balancer or even just scaling vertically the instance (more bandwidth, more CPU). It might be also as stup… woups simple as bumping up or configuring PHP pm (static). I think it’s a really bad rep for people crossing this forum when taking a decision to use nextcloud or not.

image

So the issue with the forums is kinda weird, the IP stack on the server is seriously broken around MTU/MSS handling. If you do not have a 1500 MTU capable internet connection (aka you’re on VDSL, ADSL, anything with PPPOE, etc), then you’ll have issues with the nextcloud forums.

Usually you’ll see this if your router doesn’t have clamp-mss (also know as adjust-mss) configured, and the remote site has incorrectly had ICMP completely firewalled. However in this case, the forums are also ignoring the requested MSS in the SYN packet…

Looking at a tcpdump here, I’m watching my workstation send a SYN packet with an mss of 1440. And then five packets later, the server sends back a 1500 byte packet! (an MSS of 1440 should have resulted in maximum packet sizes of 1480) My upstream router (which has a 1500 MTU and has the pppoe session from my VDSL landing on it) then sends back an ICMP Frag Needed packet (mtu 1480), the forums send back a few more 1500’s, and then finally start sending 1480 packets… Which is how things are supposed to work. Except then on the next fetch (i.e. each of the css files, jpegs, etc etc) we go through the whole rigmarole AGAIN.

This thing of it happening AGAIN should not happen - the kernel’s IP stack should be caching the MTU to the destination IP and just using it - and of course, it should be honouring the 1440 mss (1480 MTU) in the first place.

Not sure if whoever looks after the server hosting the forums is around, but if you can check that a) you’re not blocking ICMP frag needed packets, and
b) there’s no weird firewall rules set to adjust the mss of inbound packets anywhere in front of the server?

1 Like

It is not slow for everybody and not all the time. So there might be different issues and people are affected differently. There were some general problems and it was slow for everybody (many 5xx errors and some images/resources not loading and running into timeouts). Some of the things were fixed. But not for all.

I can ping help.nextcloud.com and set a MTU of 1470:
ping help.nextcloud.com -f -l 1470
I get packages of the same size back.

Oh good point, so yeah, they are actively ignoring mss in the syn packet, and the icmp frag needed packets

I am getting different results from different browsers. the site has always been really slow to initially load, but my Firefox browser has been completely failing to open the site now for a couple of months. Pages will sit on the “Loading” screen for days. Literally. Why they don’t time out, I don’t know.

I managed to get the site to load up using Chromium, though it was as usual very slow for the first page load. I’m coming from Australia, no VPN.

The issue seems to be with some of the underlying resources. Once logged in, the site seems to move between pages fairly quickly.

1 Like

3 posts were split to a new topic: Forum has a lot of CSP errors

I am also located in Australia, Sydney to be precise. Ever since i started using NextCloud and accessing the forums >12 months ago, I too have noticed that the site is always slow.

I found this thread trying to find out if there was a way to resolve it as I can generally go and make a coffee before the page I want to view is accessible :slight_smile:

What is the load balancer that runs in front of it? In case its of any use I see coloured dots cycling through constantly until the page finally loads.

When I can get in front of my PC I will do some fuether tests

I also spotted something about VDSL and MSS. I am using NBN which is VDSL through a Fortigate firewall. I will see if the Fortigate can force a particular MTU when hitting this domain to see if that helps.

P.S. this is the only site / domain I have these issues with, everything else loads in seconds.

1 Like

@mackov83
Maybe you find more infos the browser developer tools (e.g. F12 and then Network).

I get sometimes blocked http objects. I use no firewall and i can load the urls directly without problems.

Maybe interesting for @tflidd

downloadable font: download failed (font-family: “Open Sans” style:normal weight:300 stretch:100 src index:2): bad URI or cross-site access not allowed source: https://nextcloud.com/wp-content/themes/nextcloud-theme/dist/fonts/OpenSansLight.ttf

(direct link works fine for me)

1 Like

@devnull yes, I always forget about the F12 option. Here are the outputs:

On initial attempts to access the site I receive the following:

After a few minutes of waiting, it seems to then timeout with the following:

Based on my limited knowledge and reading this thread, there are two distinct sites:
https://nextcloud.com - which is a WordPress site (will refer to as ‘the website’)
https://help.nextcloud.com - which is Discourse (will refer to as ‘the forum’)

By the looks of the errors, the forum is trying to access content on the website and due to CORS restrictions it is being blocked. Weirdly when it eventually times out we then get access to the site.

I guess it’s up to the NextCloud folk to take the information we have provided and look into it.

4 Likes

Ironically I have always found it seriuosly slow to point of mind-boggling that the slowest site I ever use is help.nextcloud.com. Not a mark of honor. Then yesterday it wasn’t loading at all. And so I tried a proxy, but not luck there either, so I tried Tor too and am on Tor now, the only way I can see or interact with this forum.

Lift thy game, Nextcloud! Lift thy game.

Can you share the location and the service provider? And the proxy, is this a public one and in which network?
With the TOR network, you know that you and Nextcloud have the bandwidth to have a better connection.

I’m in Hobart, Tasmania. Service provider is TPG (Retail) and NBN (provider), and the proxy was ProxySite.

Hardly relevant though because: from this site I surf the internet, use all its diverse services and server websites and webservices from it all day every day, with top performance, streaming movies as desired, and never have any performance concerns. Until I hit help.nextcloud.com. Then it’s over, red rover.

Seattle, WA (USA) user here with fiber gigabit via CenturyLink. No VPN, proxy or whatnot. No issues with any other site, just this one.

Initial loading of any forum page takes 4+ minutes regardless of browser, OS or device. After logging in and refreshing a page I already visited it takes about 10-20 seconds.

Traceroute shows nothing odd:

$ traceroute help.nextcloud.com                                    
traceroute to help.nextcloud.com (95.217.53.146), 30 hops max, 60 byte packets
 1  * * *
 2  tukw-dsl-gw67.tukw.qwest.net (xxxx)  3.362 ms  3.292 ms  3.400 ms
 3  tukw-agw1.inet.qwest.net (xxxx)  3.702 ms  3.797 ms  3.429 ms
 4  * * *
 5  ae2.2.edge1.Helsinki1.level3.net (4.69.161.98)  179.301 ms  179.550 ms  179.765 ms
 6  212.133.6.2 (212.133.6.2)  179.807 ms  178.501 ms  182.783 ms
 7  core32.hel1.hetzner.com (213.239.224.26)  179.123 ms  179.945 ms  183.204 ms
 8  ex9k2.dc2.hel.hetzner.com (213.239.224.146)  178.760 ms  182.672 ms ex9k2.dc2.hel1.hetzner.com (213.239.224.142)  180.816 ms
 9  s5.nextcloud.com (95.216.247.163)  178.874 ms  179.042 ms  178.807 ms
10  help.nextcloud.com (95.217.53.146)  178.623 ms  178.489 ms  178.969 ms

Like @mackov83 I also get lots of blocked CORS requests.

To give perspective, the WaniKani discourse, a Japanese language learning community, takes about 2 seconds to load on a fresh laptop that has never visited the site before.

1 Like

Unfortunately, it’s not that obvious. How do you explain that it works better with TOR network.
I have no idea what is wrong, but peering can be a factor that is hard to analyze (https://www.hetzner.com/presse-berichte/2015/01/156830) and if it’s not filled up links, there can still be configuration problems in some networks, firewall settings etc.
This is the reason we ask for the destinations and operators, if we can find some pattern for users with slow connection.

1 Like

I came across here from this conversation…

https://help.nextcloud.com/t/help-nextcloud-com-is-very-slow/133237/17

Like others I’m also having issues with the forum and have had for a very long time. I started using NextCloud on a personal server in the beginning of 2020. I rarely use this forum because of load time issues. It would be a godsend if the issues could be resolved. The load times seem to be better than I first tried using it. It may be only the first page load that is extremely slow after that it seems to speed up. Perhaps something to do with setting up cookies or session configuration. I really have no idea.

Firstly lots of Kudos for the team at NextCloud. This is a valuable piece of software for backing up my personal data. Although I am considering moving to an online paid service because of security concerns of configuring my own server.

Here is a redacted tracert output.

… Previous hops hidden
8 181 ms * * port-channel6.core3.sjc1.he.net [184.104.195.113]
9 * 185 ms * port-channel1.core4.sjc2.he.net [184.105.223.126]
10 181 ms 177 ms 183 ms 100ge4-1.core1.sjc2.he.net [184.105.64.4]
11 * * * Request timed out.
12 235 ms 237 ms 238 ms 100ge13-1.core1.nyc4.he.net [184.105.81.106]
13 * * * Request timed out.
14 * * * Request timed out.
15 333 ms 331 ms 336 ms amsix-gw.hetzner.de [80.249.209.55]
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
Continues Request timeout for 30 hops …

1 Like

Just closed both browsers (Chrome and Edge) and restarted my computer. Load times seem too be OK now.
I’m also on TPG in Australia.

1 1 ms <1 ms <1 ms 192.168.3.1
2 2 ms 3 ms 1 ms 192.168.1.1
3 12 ms 11 ms 12 ms Hidden
4 14 ms 12 ms 13 ms Hidden
5 25 ms 25 ms 25 ms Hidden
6 29 ms 31 ms 30 ms Hidden
7 170 ms 171 ms 170 ms las-b24-link.ip.twelve99.net [213.248.95.232]
8 225 ms 227 ms 228 ms ash-bb2-link.ip.twelve99.net [62.115.121.221]
9 228 ms 229 ms 230 ms nyk-bb2-link.ip.twelve99.net [62.115.136.200]
10 315 ms 311 ms 308 ms kbn-bb2-link.ip.twelve99.net [80.91.254.90]
11 314 ms 316 ms 313 ms s-bb2-link.ip.twelve99.net [62.115.139.172]
12 327 ms 321 ms 322 ms hls-b3-link.ip.twelve99.net [62.115.122.35]
13 321 ms 321 ms 320 ms hetzner-svc076536-ic365572.ip.twelve99-cust.net [62.115.52.255]
14 320 ms 320 ms 322 ms core32.hel1.hetzner.com [213.239.203.209]
15 319 ms 320 ms 325 ms ex9k2.dc2.hel.hetzner.com [213.239.224.146]
16 324 ms 324 ms 321 ms s5.nextcloud.com [95.216.247.163]
17 421 ms 320 ms 320 ms help.nextcloud.com [95.217.53.146]

I note the different path it is taking in this tracert.

1 Like

Accessing from a german cable provider and cloudflare dns the forum is blazing fast.

2 Likes

Whenever I try to got to these forums, the page loading time is extremely slow. Sometimes I am waiting up to a good 2-5 minutes. Sometimes the webpage just won’t load all together and I just get a blank white page. I have tested on Mac and Windows and on Firefox, Chrome, and Safari and get the same results. This can be quite annoying at times because I often come to this site to regularly view forum posts and get help. All other sites I visit load in a second or less. My internet download speed is roughly 50-60mb/s and I am located in Australia.

Any ideas on why this is?

2 Likes

It can be that the server is saturated, or it is a bad network connection between the providers. Nextcloud uses Hetzner, you can use a looking glass service to see which way the packages pass and where the bottleneck is: Point in Germany, Falkenstein, data center Hetzner from SpaceCore

Usually they have a pretty open peering policy and present at multiple points in Europe, for overseas they rely on larger carriers (see the transit providers https://www.hetzner.com/unternehmen/rechenzentrum/). Sometimes, end-user providers have bad peering connections to these larger carriers.

We can perhaps get an idea, if you can post the mtr output to your home connection (you can anonymize your own ip, the interesting part is when it reaches your ISP’s network).

I’m also in Australia and experiencing this issue. It’s a consistent problem and not something that comes and goes, so I don’t think it’s a server load issue. I find it takes minutes to load any pages on the forum as Artichoke1 said.

I can provide mtr output, but could you explain what you’re looking for? My home network to help.nextcloud.com or from Looking House to my home network?

3 Likes