There is a problem when opening with Excel

Nextcloud version (eg, 10.0.2): 12.0
Operating system and version (eg, Ubuntu 16.04): CentOS6
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4
PHP version (eg, 5.6): 7.1

Is this the first time you’ve seen this error?:
No. This was the same as in version 10.

Can you reliably replicate it? (If so, please outline steps):
I do not know this. Is it a problem with our PCs?
But it is the same on 4 PCs.

The issue you are facing:
It takes time to open the file. Or fail.

Also, it has its features.
I am connecting nextcloud as a network drive in Windows 10.
I will try to open Excel file on drive directly with Excel(2010/2013).
Then I will ask the network drive account from Windows. This is always required even if I save account information. And I waited a few minutes and the file will finally open.
But when I open the file with LibreOffice, such a problem does not occur. The file is opened smoothly immediately. I can not ask for an account from Windows, nor will I wait.

The Word file is similar. In other words, I am bad with Microsoft Office.
I used ver.10 before ver12. It was the same then.

Please tell me how to solve this problem.

You are connecting directly to NC’s data folder via SMB network share? Please don’t do this… it’s evil. Or are you using NC client app? If not then there’s no wonder that you’re prompted for your Windows account each time. Sorry to say this but to me your issues have something more in common with your network architecture than with NC or Office itself.

Thank you for your reply.

net use x: /user:ACOUNT PASSWORD
net use x: /user:ACOUNT PASSWORD

I am connecting with one of the above.
Is this the SMB protocol?

Hi @zoo3,

No, what you are using is not SMB, it is (web) DAV.
I know that MS Office has some security measures when it comes to opening files from network sources. Maybe this causes problems here. When the files open sometimes and sometimes fail to open, it sounds like a timeout issue to me. Do you see something in the web server logs or in the nextcloud log regarding this connection and maybe a timeout?
The logs could help anyway, so please post them.

I don’t know if there is a way to change the timeout values for connections to Nextcloud. But maybe you find something in the forum here or in the Docs.
Anyway, what you could also look at, are the options of the MS Office Trust Center. There are settings for “Secured View” (don’t know the correct english translation) and “External Content” and so on. By default Office checks the file content and it’s origin first, before opening it. This check might take a while and it might also take a while for the Office app to start the document with blocked content to secure the user. This is all good for security, but I also see that this delays the opening of documents very often.
Hopefully this helps. Good luck!

Perhaps this issue is the problem with the link below?

Q: Accessing your files from Microsoft Office via WebDAV fails.

  1. Go to the your Nextcloud instance via your favorite Web browser.
  2. Click through until you get to the certificate error in the browser status line.

What is “Nextcloud instance”?
Is this a “page information(Control + Shift + P key)” menu in Firefox?
But I do not see “certificate error”.

You quoted the wrong part of that documentation. The Question for problems when opening a Office File via WebDav had a link to that MS article:,webdav-or-site-when-it

You could try to follow that one.

I think that it is an article on the problem of “http” connection (non SSL).

But I think SSL connection has been established.
“Network” in the left pane of Windows Explorer. There is also an icon “” displayed.

Hello guys, I have the same problem as zoo3.
Last monday morning (08/28), all of my users were unable to reach the network drive (webdav) on windows (7, 8.1 and 10).
I proceed an update (11.0.4), it did fix the network drive (for some users only), but since then Microsoft office documents take ages to open, and windows credential prompt pop each time a document is open.

Does any one find a solution to this ?

What I already tried :

  • security options in excel (trusted domain & protected mod)
  • internet options (white list domain)
  • different configuration in the nginx conf with security protocols
  • registery keys (UseBasicAuth & BasicAuthLevel)
  • the incompatibleUserAgents for windows in the NC conf
  • different mounting url syntax
  • all update on windows

Thanks, have a good day.

Nextcloud version : 11.0.4
Operating system and version : Debian 8
Apache or nginx version : Nginx 1.6.2
PHP version : 5.6

Nobody seems to find the solution, that’s a bit sad but I guess it is a bit windows related.
I kinda fix it by truncate the oc_bruteforce_attempts table.
I also disabled the brute force protection in the config file:
Adding "‘’ => false, " in server/config/config.php.

My guess is that whenever you want to reach a webdav server, windows make multiple calls (that’s why credential prompt pop multiple time) therefor it falls in the oc_bruteforce_attempts and then block the futur calls, and mess with the windows/office security.

As exemple, we tried to mount a network drive of the server from a new computer, we tried to connect once, two credential prompt poped, and it result in 7 lines in the oc_bruteforce_attempts table about this user.

Does anyone can confirm if that it is related or not ?

In my case, this problem occurs when opening a file created by MS Office. I create it with LibreOffice and save it to Excel format(xls/xlsx) on Nextcloud drive. When opening it with MS Office, I can open it without authentication.

I hope this will be a hint.