Theming not working on version 28.0.3

A newly fresh installation
version: 28.0.3 (latest according to your site)
PHP: 8.2
MSql: 8.0

I installed NC on a from scratch… but theming is not working!
I disabled all Apps, same thing! Nothing workis if I want to customize the site!
I looked int the forum… but couldn’t get a help!

Even if I upload a logo or a background image or even change he color… nothing works!!!
Any help plz?
Thank you.

Normally theming should be like this

But I have it like this

Any help or whihc version is stable and doesn’t have theming problems§
Thank you.

Everything works as expected for me on 28.0.3.
Can you give us more information? What browser? Any plugins (like Ad-Blocker, noScript,…)? Did you login as the admin-user? Maybe give us the information that is asked for in the support template?

Seems to be a client side problem or a problem with CSS. Test another browser and use in your browser developer option F12 (network analysis). Post HTTP-codes with not 200.

I tried both on Chrome and Edge.
Yes i am using the Adblock Plus plugin on Chrome. But that is discativated on my domain…
I logged as an admin of course.
this is errors i get under security and setup errors:

if I click on “list of invalid files” i get this:
Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix


  • core
      • core/doc/admin/_sources/configuration_server/domain_change.rst.txt

Raw output

[core] => Array
[core/doc/admin/_sources/configuration_server/domain_change.rst.txt] => Array
[expected] => 6379a648a01dbae201d518aa3b37259dab3d41f73c88bfadf8248f34987827658e2340b3af7e0a7dd1b02813bab1933a083e03d883ada31b8143e6093989c688
[current] => e3029a486c5fc2cab69df4eec50fe28be3fcb4d7da4ccdf8ef53c61561c54249b4584a66a62de1ae23be8d7a16b9be607678d7a94a92d4298d4991de6c4ef147

One of the errors is that php is not setup correctly. That is one issue to look at.

This seems to be that it doesn’t load the css correctly.

@SmallOne @devnull

When I open the developer option, i have this fixed error

So the css is not loading!


Maybe you can search NS_ERROR_NET_PARTIAL_TRANSFER. Also see your HTTP version. Which version do you normally use? Do you use a proxy, filter, reverse proxy, … Deactivate all or use a browser/pc on another network.

By http; do you mean the http/https or the http 2?

I am not behind a proxy or any kind! I changed the computer, the network, on mobile, tabled… still same…
But the login page works fine!

I just noticed something for theming…
only links of theming has mydomain/index.php/apps/theming/theme/…
the dashboard ass well it is mydomain/index.php/apps/dashboard
while all other instances has mydomain/apps/…
any hints!

There is not theme folder in theming!
so for example the follwoing link
gives an erro “not found”! because /apps/theming/theme doesn’t exist!

I have tried to access the website and get a directory view. Even the seemingly accessible subpages are not available. It seems to me that something is wrong with the web server configuration.

Yes, that is true… I am deleting all files and will reupload and install all over again! new directory, new database etc…
but, do you have any explanation why the theme folder is not in the /theming/ ?

I also can not find the folder on my Nextcloud. Maybe a Rewrite.

Do you think that maybe the use of PHP: 8.2 and MSql: 8 is a problem?
in their documentation, they said 8.0 is recommended!

8.0 (deprecated)
8.2 (recommended)

System requirements Nextcloud 28

I don’t think it should be a problem. But I don’t know either. Which operating system do you want to use for the new installation? At least you don’t have to use an external PHP source. Neither with Ubuntu 22.04 LTS, 24.04 LTS or Debian 12 Bookworm.

I will try the 29 version to see if it works.
I have a vps, but i don’t know how to link the subdomain to the vps:) i can install Ubuntu on it.
I use a shared hosting with ovh.
I am not an expert:) so i don’t use the vps:)

I created a new subdomain, new database… nothing…same problem…
I even hosted the files in another hosting… nothing…same problem…
I tried the version 29… samething…
I think it is a server problem! but as I have a shared hosting! i don’t know the exact problem!
I have 2 other installations with versions 22 and 23, but they are working fine!