Theme gone after upgrade to 25, 26RC1 or 27.0.1

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Hello there,
After upgrading to 25 my theme does not load anymore on FirefoxAurora while it’s ok on Safari.

Nextcloud version (eg, 20.0.5): 25.0.3
Operating system and version (eg, Ubuntu 20.04): Debian GNU/Linux 10 (buster)
Apache or nginx version (eg, Apache 2.4.25): 2.4
PHP version (eg, 7.4): 8.0.19

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. I upgraded from the UI from 24 to 25 on FirefoxAurora

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ochbebh6olrp',
  'passwordsalt' => '*****',
  'secret' => '*****',
  'trusted_domains' => 
  array (
    0 => 'cloud.*****.org',
  ),
  'datadirectory' => '/home/*****/data',
  'overwrite.cli.url' => 'https://cloud.*****org',
  'dbtype' => 'mysql',
  'version' => '25.0.3.2',
  'dbname' => '*****',
  'dbhost' => '*****.clouddb.ovh.net:35876',
  'dbtableprefix' => 'oc_',
  'dbuser' => '*****',
  'dbpassword' => '*****',
  'logtimezone' => 'UTC',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\ArrayCache',
  'integrity.check.disabled' => true,
  'mail_from_address' => 'emmanuel',
  'mail_smtpmode' => 'smtp',
  'mail_domain' => '*****.org',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'log_type' => 'file',
  'logfile' => '/home/*****/data/nextcloud.log',
  'mail_smtphost' => 'ssl0.ovh.net',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'postmaster@*****.org',
  'mail_smtppassword' => '*****!',
  'mail_smtpport' => '587',
  'updater.secret' => '*****',
  'app_install_overwrite' => 
  array (
    0 => 'occweb',
    1 => 'nextbox',
  ),
  'updater.release.channel' => 'stable',
  'default_phone_region' => 'FR',
  'mysql.utf8mb4' => true,
);

The output of your Apache/nginx/system log in /var/log/____:

Before I reset the logo from the admin panel trying to fix my issue, I had 404 responses on the logo.

[25/Jan/2023:18:23:04 +0100] "GET /index.php/apps/theming/image/logo?useSvg=1&v=5 HTTP/1.1" 404 22564 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:04 +0100] "GET /index.php/apps/theming/theme/light.css?plain=1&v=5860df9e HTTP/1.1" 200 1034 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:04 +0100] "GET /index.php/js/core/merged-template-prepend.js?v=f9a214ea-5 HTTP/1.1" 200 3098 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:10 +0100] "GET /index.php/apps/theming/favicon/dashboard?v=5860df9e HTTP/1.1" 200 90022 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:10 +0100] "GET /index.php/apps/theming/icon/dashboard?v=5860df9e HTTP/1.1" 200 11425 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:10 +0100] "GET /index.php/apps/theming/theme/light-highcontrast.css?plain=1&v=5860df9e HTTP/1.1" 200 1092 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:10 +0100] "GET /index.php/apps/theming/theme/dark.css?plain=1&v=5860df9e HTTP/1.1" 200 1026 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:10 +0100] "GET /index.php/apps/theming/theme/dark-highcontrast.css?plain=1&v=5860df9e HTTP/1.1" 200 1114 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:10 +0100] "GET /ocs/v2.php/search/providers?from=%2Fapps%2Fdashboard%2F HTTP/1.1" 200 261 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:11 +0100] "GET /apps/calendar/img/calendar-dark.svg HTTP/1.1" 200 820 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:11 +0100] "GET /apps/user_status/img/user-status-invisible.svg HTTP/1.1" 200 284 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:11 +0100] "GET /apps/dashboard/img/dashboard.svg HTTP/1.1" 200 475 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:11 +0100] "GET /apps/calendar/img/calendar.svg HTTP/1.1" 200 820 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:11 +0100] "GET /apps/contacts/img/app.svg HTTP/1.1" 200 2802 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"
[25/Jan/2023:18:23:11 +0100] "GET /apps/notes/img/notes.svg HTTP/1.1" 200 404 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0"

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

I found this error that might be relevant. dunno😕 maybe.

Erreur	index	OCP\Files\NotPermittedException: Could not create folder
/home/bardet/cloud/lib/private/Files/SimpleFS/SimpleFolder.php - line 106:
OC\Files\Node\Folder->newFolder("11")
/home/bardet/cloud/apps/theming/lib/ImageManager.php - line 165:
OC\Files\SimpleFS\SimpleFolder->newFolder("11")
/home/bardet/cloud/apps/theming/lib/ImageManager.php - line 180:
OCA\Theming\ImageManager->getCacheFolder()
/home/bardet/cloud/apps/theming/lib/Controller/IconController.php - line 124:
OCA\Theming\ImageManager->getCachedImage("favIcon-settings")
/home/bardet/cloud/lib/private/AppFramework/Http/Dispatcher.php - line 225:
OCA\Theming\Controller\IconController->getFavicon("settings")
/home/bardet/cloud/lib/private/AppFramework/Http/Dispatcher.php - line 133:
OC\AppFramework\Http\Dispatcher->executeController(OCA\Theming\ ... {}, "getFavicon")
/home/bardet/cloud/lib/private/AppFramework/App.php - line 172:
OC\AppFramework\Http\Dispatcher->dispatch(OCA\Theming\ ... {}, "getFavicon")
/home/bardet/cloud/lib/private/Route/Router.php - line 298:
OC\AppFramework\App::main("OCA\\Themin ... r", "getFavicon", OC\AppFramew ... {}, [ "settings" ... "])
/home/bardet/cloud/lib/base.php - line 1047:
OC\Route\Router->match("/apps/themi ... s")
/home/bardet/cloud/index.php - line 36:
OC::handleRequest()

Just to add up, I tried on firefox with all extensions off, troubleshoot mode and/or private window. No change in behavior.

I had to re-apply some of my theme settings after the upgrade. I did notice though that the folder icons and favicons are now the default color… I haven’t tried in another browser.

Looks like you hit a bad time to update. v25.0.3 is the first release since ages having issues with theming and logo. Personally I upgraded from v25.0.2 and hit the same. I am waiting for v25.0.4 to get this fixed again. Have no link at hand, sorry.

1 Like

Aurora is the alpha release, so have you tried regular Firefox stable build?

More specifically, Aurora was a channel between the nightly builds and the beta builds, which was discontinued in 2017 !! :wink: https://release.mozilla.org/firefox/release/2017/04/17/dawn-project-faq

Hello @just, thanks for your suggestion. I tried, yes, and it’s even worse. In addition, some strings do not show as expected at all. For instance “Définir le statut” becomes “!E-, ojs!rfi!tubuvu”.

Yes, @bb77, it’s actually the Dev Edition 110.0beta Firefox Beta January 17, 2023.

Yeah i thought so… I just wanted to point it out. :wink:

Anyways, unfortunately I can’t say much about your actual issue, since everything is working for me, except for this small bug… [Bug]: Avatar New style looks weird · Issue #34006 · nextcloud/server · GitHub

Btw. I’m using the stable release of Firefox, which currently is on 109.0.1.

Also, I have the same behavior with Chrome 109.0.5414.119 (Build officiel) (arm64).

So, to sum up, I’m running Nextcloud 25.0.3 and I have no theme on Firefox, Firefox Beta and Chrome while it’s just fine on Safari.

Must be specific to your setup. Mine has never had any issue with any browser. Good luck with it. Bowing out of this.

I have the same problem on firefox 109.0.1 no theme setup is applied.
no scrollbars are visible .

no theme and no scrollbars

Hello @Christophe_Filippell It indeed looks like the same issue. I guess the scrollbar is there but both foreground and background colours are white. I’m waiting for Nextcloud 26 to check whether this behavior remains.

Hello here,

Back with some updates. I updated to 26RC1 but it does not change anything.

  • I noted that the GETs to dark.css, dark-highcontrast.css and light-highcontrast.css take more than 5 seconds to get back
  • Also, these 3 files get called 3 times
  • The page is displayed at the return of the 2nd call and a 3rd one is triggered after that

I wonder whether this is a lead however, I don’t have enough knowledge to investigate but I could well do if directed. Would anybody be kind enough to let me know the next steps?

Thanks for any help.

E

PS : all the navigators show the same now.

I hope this helps people following on. I upgraded from v23 to v24 in a docker. I used linuxsefvers docker version 24 image and then upgraded using /updater/updater.phar

I left my config and nginx config files in place.

This went off without a hitch after sevwral attempts to upgrade within the existing docker failed.

I did the same with upgrading from v24 to v25.
I had the same issue described above.

I ran occ maintenance:theme:update to resolve it.
I restarted the Nextcloud docker as well.

Same problem here. I looked a bit into it, and this is a potential fix:

cd /var/www/html
mkdir apps/theming/theme
cp apps/theming/css/default.css apps/theming/css/theming.css apps/theming/theme

Could someone try and report if this makes the problem better?

Hello @aannoaanno
Nope. This did not change anything on my case.

I updated nextcloud to 27.0.1 and the error remains at each stage. I noticed the css files delivered by index.php are all rejected regardless of the web browser I use (while they all get back with an http status 200). For instance, Chrome reports: net::ERR_HTTP2_PROTOCOL_ERROR 200

After digging the web, I found recent browsers can see a difference with the content-length in the header when these are served zipped. Thus, I am trying to prevent my Apache to zip them by touching the .htaccess but my low level of knowledge does not help. I can tell that these lines below do not work :frowning:

SetEnvIfNoCase REQUEST_URI ^/index.php/*.css$ no-gzip dont-vary
SetEnvIfNoCase REQUEST_URI ^/index.php/apps/theming/theme/*.css$ no-gzip dont-vary

Hello all,
Quick update to keep the info for others too.
I managed to get it working from Firefox by desabling gzip:
– Go to Firefox about:config
– search for network.http.accept-encoding
– and empty it (default is gzip, deflate)
The theme is back then. This shows the problemn is definitely with the css files delivered by index.php. They most likely do not get their content-length properly set according to the proper size of the file gzipped. Well… it’s my guess. As of now, I did not manage to prevent zipping on those files from the server yet.

OK. For the record, I ended up preventing gzip compression for css files delivered by index.php (since navigators reject them for a reason I have no idea why) by adding this below line to .htaccess.

SetEnvIfNoCase Request_URI .*index.php.*css no-gzip dont-vary

1 Like