The user limit of this instance has been reached

I’m using the AIO instance of Nextcloud, provisioned as an Azure instance.

I have added my users via LDAP. We also have a few regular external users who will require access to the system so I am trying to add them in manually via “Add User” in Nextcloud.

However… I am getting an error when I try to add a user that looks like this:

2022-10-17_09h42_12

I looked into the notification section and saw this:

2022-10-17_09h42_28

Am I correct in thinking that if the software is OpenSource, then I should be able to add unlimited users? Or is there something I can do to get around this. I’m being quoted thousands of £ for a premium subscription simply because I’m unable to add more users.

Thanks in advance.

Furthermore, I’ve been told the user limit on the community version is 500.
2022-10-17_13h06_27
I appear to be under this limit.

No. You do not need it. Nextcloud AIO is free software with license AGPL v3. I think there is no community limit possible in this part of the software.

I do not use LDAP but maybe a LDAP problem.
LDAP uses $pagingSize == 500.

$maxResults = $pagingSize > 20 ? $pagingSize : 500;

Maybe you can test changing line 205 (apps/user_ldap/lib/Access.php) to

$maxResults = $pagingSize > 20 ? $pagingSize : 1000;

https://github.com/nextcloud/server/blob/master/apps/user_ldap/lib/Access.php

I tried this and it didn’t seem to make a difference.

In the Nextcloud config.php I’ve noticed a user limit. I’ve tried changing this to 500 too. But each time I update the entry, when I restart the container it resets back to 100. I’m not sure if the issue relates to that though.

2022-10-17_14h24_56

If I change this 100 limit to 500 whilst the instance is running, then it works… It lets me add users. But as soon as I restart the instance, it defaults back to 100?

Sorry i do not use Nextcloud AIO. But i think you must make config.php persistent.

https://github.com/nextcloud/all-in-one#how-to-edit-nextclouds-configphp-file-with-a-texteditor

Hi! I have the same issue since (and maybe a bit before?) updating to 25.0.0. I can’t add any more users, which is a serious issue for us right now.

The user limit has been reached and the user was not created.

We’re currently at 138 users, which should not be and never was a problem.

I’m not running Nextcloud Enterprise or AIO, but the regular, normal, stable version. I do not use LDAP.

Adding works neither via web nor via occ. Error message is the same.

I also had these 2 config options show up in my config.php:

  'one-click-instance' => true,
  'one-click-instance.user-limit' => 100,

they are not documented anywhere (web docs or documented config), so i don’t know where they come from or what they mean. Changing the user limit or disabling the first option does nothing in my case, both when restarting and not restarting NC. But it also doesn’t reset itself the way it does for @CAdavida1992 . Might be an Azure thing in their case.

Any help would be greatly appreciated, this is really halting our operations right now since we can’t onboard new members. Thanks in advance!

System Data:
Nextcloud 25.0.0.18 Build 2022-10-18T08:34:52+00:00 20ea9a25353129b56d46951fe7d23939665ab2b2
FreeBSD 12.2-RELEASE-p12 (Jail)
PHP 7.4.32
mysql 8.0.30
nginx 1.22.0
redis 7.0.5

cc @szaimen

The user limit for AIO is documented here: All-in-one - Nextcloud

1 Like

@kesselb
What is correct?

a.)

For very small installations (<100 users) this is 100% free, though without any service or guarantees. For slightly larger installations (>100 users) we offer Nextcloud Enterprise, with support SLA, security information and all benefits that come with our enterprise product.
https://nextcloud.com/all-in-one/

b.)

GNU Affero General Public License v3.0

all-in-one/LICENSE at main · nextcloud/all-in-one · GitHub

Is it not 100% free for >100 users without any service or guarantees? I do not want to be misunderstood. I think enterprise support is good and important, especially in commercial environments. But doesn’t the license say otherwise? Or is there a difference between <100 and >=100?

Hi,

I shared the official document here to avoid further ambiguities.
The All-in-one has a user limit of 100.

I’m unable to answer questions regarding licensing.

2 Likes

@szaimen Can you answer this question?

No, I am not a lawyer

2 Likes

I will close this now as the initial question was answered.