The user limit for this instance has been reached

Hi everyone! I whould greatly appriciate some help.

Struggling to add LDAP users into my fresh nextcloud AIO installment. Experiancing following notifications:
At https:///settings/admin/logging:

"The user has not been created, and the limit on the number of users has been reached."

At system notifications:

"The user limit for this instance has been reached"

And then offers to enter license number…

I figured out that it has to be an issue in latest builds, after all, 100 users limitation is mentioned at All-in-one - Nextcloud. What bothers me that apparently my instance is limited up to 25 users cause it is number of users that were successfully imported before triggerring notifications above. Initially i tried to import all ~200 users but then limited quontity to only one group (79 users) which should suffice as long as i understand AIO licencing policy.
I have default values at config.php - ‘one-click-instance.user-limit’ => 100,
Tried to change this value, and restarted nextcloud-aio-nextcloud container a couple of times, but for no good. And have no idea where this “25” came from.

If anyone knows what can be the issue of such limitation and how possibly to fix this, please let me know. We don’t need huge user catalog. I hope < 100 is poissible.
Best regards.

System Data
Nextcloud version:
OS: Linux 5.15.0- #2 SMP Wed Nov 22 18:01:23 PST 2023 x86_64
Web server: Apache/2.4.58 (Unix) (fpm-fcgi)
PHP version: 8.1.26
Database: pgsql PostgreSQL 15.5 on x86_64-pc-linux-musl, compiled by gcc (Alpine 13.2.1_git20231014) 13.2.1 20231014, 64-bit

Welcome to the community @sunhailer :handshake:

Please use the search - lot of issues have been discussed already like

Hi! Thank you so much for the quick reply.

Considering the solution that was mentioned by jmf in the link above, I tried to play with $hardUserLimit in Registry.php which resulted in nothing. Then I noticed that at “users” menu only specific user names are shown, which are relevant to my destinct AD group, but in “contacts” menu there are much more users that belong to the rest of DC. My conclusion is that Nextcloud polulated db with user accounts upon initial import when there were no limitations and those old accounts are counted in the first place which prohibits me to add new ones. Apparently they were not removed automatically with new LDAP import. Strangly enough I couldn’t remove them myself from contacts since I hadn’t rights to do so as a default admin. Either way I miss somethings or such behaviour is purposely intended. How to remove given contacts or users from instance is an interesting question for me but for another time considering current topic. Anyway, since it was a fresh installation, i started from the beginning all over again, this time used group limitation in settings from the get go as well as changed $hardUserLimit to 100. And it worked! All 79 users were successfully imported.

I suppose, this question was answered. Thank you for help! Happy Holidays!

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.