The server address setting is wrong

installation nextcloud(docker ), the server address setting is wrong,in the menu [Mobile & desktop] in the personal settings of the system, 。Causes the PC client (desktop)to access the server address to be wrong。

I’m having the same issue. I set the correct overwrite cli url, but it does not change the url there. If you ever found the solution…? Please share. :slight_smile:

For some reasons, using config.php does not work.
I was able to set the correct value in “server address” by setting the following environment variables while creating nextcloud container : OVERWRITECLIURL, OVERWRITEHOST, and OVERWRITEPROTOCOL.

Here is an example of of the command line I’ve used :
docker create -v nextcloud:/var/www/html -v /mnt/dockerdata/nextcloud:/data -p 8094:80 --env OVERWRITECLIURL= --env --env TRUSTED_PROXIES=192.168.1.x --env OVERWRITEPROTOCOL=https --restart=unless-stopped nextcloud