The editor is loaded with the "The document could not be saved" message


#1

I successfully loaded Docker and the OnlyOffice Document server and connected it with NextCloud.

But when I try to create and edit a document I receive an error message:

“Find more information about connecting Document Server” - https://api.onlyoffice.com/editors/callback

And this is what another part of their site points to solve the issue but I don’t quite understand it.

The editor is loaded with the “The document could not be saved” message.

The document editing service cannot connect to the document storage service at the editorConfig.callbackUrl address.

Check if the Callback handler is working correctly. The document storage service must return {“error”: 0} in response.

Error in NextCloud Logs:

Error	onlyoffice	CommandRequest on check error: Error occurred in the document service: Error while downloading the document file to be converted.	2017-08-28T02:59:41+1000

Has anyone else had this issue and resolved it? @JasonBayton


#3

Could this be linked to this former issue somehow? However, NC 12.0.2 and Collabora Office 2.1.3 with active Collabora Online 1.12.34 App are providing the service as appropriate now. @TP75


#4

I just enabled the Collabora app and did a test to see if I could open the Document again in OnlyOffice and this is what happened (see image)

After disabling Collabora this error screen did not appear when trying to open the document, I was back to the same error as in the last image I posted. @TP75

Edit: Im only running nextcloud on the localhost, I haven’t yet setup external access, but I setup collabora server in docker as well as well as onlyoffice document server and I just get error you see above.


#5

Hello,

The first issue that you have described is that the Document Server cannot access Nextcloud and download the file from the storage.

One of the possible solutions for CentOS and derivatives is the firewall exception:
(do not forget to change the port)
sudo firewall-cmd --zone=public --add-port=80/tcp --permanent
sudo firewall-cmd --reload

Also you could try to download the latest version of our connector. It was released few days ago. Unpack it to the /nextcloud/apps/onlyoffice/ => open the NextCloud config file /nextcloud/config/config.php => and add a section to it:

‘onlyoffice’ =>
array (
‘verify_peer_off’ => TRUE,
)

The second issue is connected with the Collabora Online plugin. The Collabora Online plugin works incorrectly and prevents our editors from being started by default. Please turn off the Collabora Online plugin to use ONLYOFFICE by default.

Looking forward to hearing from you.


#6

I have the same issue with a docker installation of both Nextcloud and Onlyoffice on the same Ubuntu 16.04.3 server. I have installed the latest apps version of Onlyoffice, and added the ‘verify_peer_off’=> true, but the issue persists. What did happen for me, however, is I lost the Nextcloud logo on both the log-in page and on the menu bar at the top left hand corner.

Has any solution been found with this error message in a docker installation?


#7

The address for the NextCloud installation it must be accessible by the OnlyOffice Document Server.

Change http://localhost/Nextcloud to http://ip/Nextcloud and then add the correct configuration.

The example of @petethepumpkineater is in localhost


#8

I have the same issue. I followed this installation today https://www.linuxbabe.com/docker/onlyoffice-nextcloud-integration-docker. So the installation uses all the newest files. It is NC 13.

Everything works very well. Except when I want to open a document I get a warning “The document could not be saved…”. The document is visible behind the warning. I clic OK. I am then presented to a menu saying Download and I have 4 icons for different fileformat. If I choose a fileformat I am offered to save the file to my local HDD. I do not want that and press cancel. Then I can view and edit the document. And I can save it.

If I clic OK on the warning and instead och choosing the fileformat clic on Save, I get immediately to the open document. I can edit and save.

Or I can choose “Close menu” with same result - the document is open and can be edited and saved by the “discette-icon”.


#9

This solution worked - changing “Server address for internal requests from the Document Editing Service” from http://nginx-server/ to https://nginx-server/