The downloaded file does not match the checksum, it will be resumed

Hi.
I’ve a folder shared from a foreign NC19 to our NC21, and from time to time I get the error above on some files in that directory.

As I can have access to the remote NC19 installation, I usually move the file away from its location and then put it back in place, and this usually fixes. As this is happening more than once I’d like to find a better solution.

Today I tried downloading the file from the NC19 installation and placing it in my local synced path so that my client would re-upload it, but it didn’t solve, I’m still getting the error!

Remote: NC 19.0.13 on nginx, php7.4.
Local: NC 21.0.3 on nginx, php7.4. Client 3.2.3 on macOS updated today.
The directory has been shared from NC19 to a local group on NC21.

Nothing relevant in nextcloud.log about that file, just GETs from my client with warning about:

{
  "reqId": "OwcNIVf5szx1eALr3Tla",
  "level": 0,
  "time": "2021-07-06T08:51:28+00:00",
  "remoteAddr": "84.1.2.3",
  "user": "d798d148-1234-1032-4321-676991a567b4",
  "app": "files_external",
  "method": "GET",
  "url": "/nc/remote.php/dav/files/d798d148-1234-1032-4321-676991a567b4/DOCUMENTI%20IT/Password%20IT.kdbx",
  "message": "/appinfo/app.php is deprecated, use \\OCP\\AppFramework\\Bootstrap\\IBootstrap on the application class instead.",
  "userAgent": "Mozilla/5.0 (Macintosh) mirall/3.2.3git (build 6318) (Nextcloud, osx-20.5.0 ClientArchitecture: x86_64 OsArchitecture: x86_64)",
  "version": "21.0.3.1"
}

I also have been having this problem.

I use Nextcloud on my desktop (Arch Linux, nextcloud-client 3.2.4-1) and phone (Android, 3.16.1). Sometimes when I change a file on my phone I get the same error as @maxxer, and I can’t sync the files. Moving things around doesn’t help…

Would really appreciate some help here. Thanks!

Hi all,
Same messages here sometimes too. The only solution I found is to copy the file, keep the copie and delete the first file. I am running client NC version 3.2.4 on windows 10, but it happened in some previous releases. The NC server does’nt run on my compny’s servers, but i can ask for more information if needed.

About the server :
Système d’exploitation: Linux 5.4.0-1031-kvm x86_64
CPU: AMD EPYC 7282 16-Core Processor (4 cores)
MĂ©moire: 7.78 GB

"Il y a quelques avertissements concernant votre configuration.

La configuration des entêtes du proxy inverse est incorrecte, ou vous accédez à Nextcloud depuis un proxy de confiance. Si vous n'êtes pas en train d’accéder à Nextcloud depuis un proxy de confiance, il y a un problème de sécurité qui peut permettre à un attaquant d'usurper l'adresse IP affichée à Nextcloud. Vous trouverez plus d'informations dans notre documentation.
Une tâche en arrière-plan qui vérifie les certificats SSL importés par l’utilisateur est en attente. Veuillez vérifier plus tard.
L'en-tête HTTP "Strict-Transport-Security" n'est pas configurée à au moins "15552000" secondes. Pour renforcer la sécurité, nous recommandons d'activer HSTS comme décrit dans nos conseils de sécurisation ↗.

La configuration du serveur web ne permet pas d'atteindre "/.well-known/caldav". Vous trouverez plus d'informations dans la documentation.
La configuration du serveur web ne permet pas d'atteindre "/.well-known/carddav". Vous trouverez plus d'informations dans la documentation.
Le module php-imagick n’a aucun support SVG dans cette instance. Pour une meilleure compatibilité, il est recommandé de l’installer.

Merci de consulter les guides d’installation :arrow_upper_right: et de vérifier les erreurs ou avertissements des logs."
:arrow_upper_right:
Version

XXXXXXXXXXXXXXXXXX 21.0.2

Thank you.