Test our new work-in-progress upgrader script

Thanks for your help.

the content of the file reads:

(“state”:“end”,“step”:11)

I know this doesn’t add anything much, but this worked a dream for me. I had a permissions problem because I had made a backup to updater/index.php.bak and this wasn’t owned by www-data, but otherwise it was all fine. It did disable 4 of my plugins, but I simply re-enabled them after the upgrade.

I guess the updater won’t work if my nextcloud instance is not located in the nextcloud folder (I renamed the folder)?
Is it enough to rename the folder back to Nextcloud and after the update rename it agian?

I’m already on .52 so i can’t test it.

It should work no matter how the parent folder is named.

This is most likely why the updater would not show up :wink:

Oh great, I’ll try it as soon as there is a new version to test.

Yeah, I know. I just wait till the next version gets released.

I am on owncloud 9.0.2 and want to test the new script. but sadly it does nothing.

I have yesterday uploaded the index to the updater folder and add the line in the config.
change the update channel and nothing happends. can i check somewhere why nothing happends?

Starting from NextCloud 9.051 it worked flawless and as expected!

regards, hitam4450

1 Like

Just upgraded from owncloud to 9.50 manually an then used the updater to go to 9.51. Worked very well, just - naturally! - doesn’t work with Strong Permissions

I got stuck on this error message:
Check for write permissions
The following places can not be written to:/var/www/html/nextcloud/updater/…/apps/notes/.git/objects/pack/pack-17eddcbf421e526c08aa2359c72d3cf848f58435.pack/var/www/html/nextcloud/updater/…/apps/notes/.git/objects/pack/pack-17eddcbf421e526c08aa2359c72d3cf848f58435.idxThe following places can not be written to:/var/www/html/nextcloud/updater/…/apps/notes/.git/objects/pack/pack-17eddcbf421e526c08aa2359c72d3cf848f58435.pack/var/www/html/nextcloud/updater/…/apps/notes/.git/objects/pack/pack-17eddcbf421e526c08aa2359c72d3cf848f58435.idx

It’s strange because everything in /nextcloud should have apache:apache owner.

No, but if someone has run the strong permissions script, then hopefully they read the part that warns that they’ll need to temporarily change the permissions back before upgrading… :wink:

1 Like

I did run the script that changes owner of all files in /var/www/html/nextcloud to apache:apache. And all files there seem to have apache:apache as their owner. Yet I’m told during the upgrade that some files can’t be written to.

Like me? Yeah, missed that.

Try this script (or run the lines manually)

`#!/bin/bash

chown -R http:http /volume1/web/owncloud/
chown -R http:http /volume1/web/owncloud/apps/
chown -R http:http /volume1/web/owncloud/config/
chown -R http:http /volume1/web/owncloud/themes/
chown -R http:http /volume1/owncloud/

chown http:http /volume1/web/owncloud/.htaccess

find /volume1/web/owncloud/ -type f -print0 | xargs -0 chmod 777

find /volume1/web/owncloud/ -type d -print0 | xargs -0 chmod 777
find /volume1/owncloud/ -type d -print0 | xargs -0 chmod 777

chmod 777 /volume1/web/owncloud/.htaccess`

This worked for me.

This also worked for me, just had to change the commands to:

chown -R ncadmin:ncadmin /var/www/nextcloud/
chown -R ncadmin:ncadmin /var/www/nextcloud/apps/
chown -R ncadmin:ncadmin /var/www/nextcloud/config/
chown -R ncadmin:ncadmin /var/www/nextcloud/themes/

chown ncadmin:ncadmin /var/www/nextcloud/.htaccess

find /var/www/nextcloud/ -type f -print0 | xargs -0 chmod 777
find /var/www/nextcloud/ -type d -print0 | xargs -0 chmod 777

chmod 777 /var/www/nextcloud/.htaccess

I thought I already have .52 but that was a mistake, I only had .51.
So I could also test the Updater. After setting the permissions everything worked fine without an issue.

I hope you’ll release future updates on time for the updater.

something I did not mention properly. I’m getting the following error after using the latest updater and adding the config bit

Fatal error: Uncaught Symfony\Component\Process\Exception\RuntimeException: The Process class relies on proc_open, which is not available on your PHP installation. in /www/htdocs/123456789/domain/next.domain.net/cloud/updater/vendor/symfony/process/Process.php:144 Stack trace: #0 /www/htdocs/123456789/domain/next.domain.net/cloud/updater/src/Utils/OccRunner.php(45): Symfony\Component\Process\Process->__construct(‘php /www/htdocs…’) #1 /www/htdocs/123456789/domain/next.domain.net/cloud/updater/src/Utils/OccRunner.php(56): Owncloud\Updater\Utils\OccRunner->run(‘config:list --p…’) #2 /www/htdocs/123456789/domain/next.domain.net/cloud/updater/src/Utils/ConfigReader.php(106): Owncloud\Updater\Utils\OccRunner->runJson(‘config:list --p…’) #3 /www/htdocs/123456789/domain/next.domain.net/cloud/updater/src/Utils/ConfigReader.php(50): Owncloud\Updater\Utils\ConfigReader->load() #4 /www/htdocs/123456789/domain/next.domain.net/cloud/updater/src/Control in /www/htdocs/123456789/domain/next.domain.net/cloud/updater/vendor/symfony/process/Process.php on line 144

Keep in Mind, update from .50 to .51 was fine

i have tried it yesterday again but the updater did not mention that there is a possible update.

so i tried ‘updater.release.channel’ => ‘daily’, in my config but if i login in my owncloud 9.0.2 and go to the admin section
the update channel are still on stable. this shouldn’t be right?

i would like to upgrade to have the latest security fixes. any idea how i can get it to work?

Not sure if your running on a vm or not, but you could trying taking a snapshot on vmware if u are. Or try using superduper to copy the entire machine as an iso

I try to use the updater. The updater tells me there is an new Daily build available, but when I Click Update it tells me that I have the latest Version… Any idea?

.52 is the latest so the updater is wrong. Can’t help fixing it thought