Tasks app not working after upgrading nextcloud to version 28.0.6

Hi there :wave:

After upgrading a Nextcloud instance, I am left with the app Tasks not opening.

Here is what it looks like :

Nextcloud version (eg, 29.0.5): 28.0.6
Operating system and version (eg, Ubuntu 29.04): Ubuntu 22.04.4 LTS
Apache or nginx version (eg, Apache 2.4.25): nginx/1.18.0
PHP version (eg, 8.3): 8.2

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Upgrade from Nextcloud 27.1.5 to 27.1.10
  2. Upgrade from Nextcloud 27.1.10 to 28.0.6
  3. Open Tasks app

The php version remained the same accross Nextcloud versions.

The output of your Nextcloud log in Admin > Logging:

Creation of dynamic property OCA\Tasks\Controller\PageController::$settingsService is deprecated

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'xxx',
    1 => 'xxx',
  ),
  'datadirectory' => '/data/nc-data425',
  'dbtype' => 'mysql',
  'version' => '28.0.7.4',
  'overwrite.cli.url' => 'https://xxx',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'xxx',
  'installed' => true,
  'logtimezone' => 'Europe/Brussels',
  'maintenance' => false,
  'loglevel' => 0,
  'filesystem_check_changes' => 1,
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => '0',
  ),
  'mail_smtpmode' => 'smtp',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_from_address' => 'no-reply',
  'mail_domain' => 'xxx',
  'theme' => '',
  'skeletondirectory' => '',
  'mail_sendmailmode' => 'smtp',
  'app_install_overwrite' => 
  array (
    0 => 'calendar',
  ),
  'default_phone_region' => 'BE',
  'versions_retention_obligation' => 'auto,90',
  'trashbin_retention_obligation' => 'auto,30',
  'mail_smtpport' => '587',
  'htaccess.RewriteBase' => '/',
  'trusted_proxies' => 
  array (
    0 => '127.0.0.1',
    1 => '::1',
    2 => 'xxx',
  ),
  'mail_smtphost' => 'xxx',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'no-reply',
  'mail_smtppassword' => 'xxx',
  'maintenance_window_start' => 1,
);

Any tip or help would be greatly appreciated :slightly_smiling_face:

Do you have any errors or warnings under Admin settings->Overview?

If not, please check your browser console.

Tasks definitely works in v28.

The main thing that people seem to overlook is checking the Critical Changes section of the Admin Manual before upgrading:

https://docs.nextcloud.com/server/latest/admin_manual/release_notes/upgrade_to_28.html

So my first friend your Nginx config is not up-to-date.

There was indeed an issue in Admin settings → overview concerning .mjs files not being able to be served by the webserver.

Adding these lines in the nginx config solved the issue :

location ~ \.mjs$ {
  types { text/javascript mjs; }
}
1 Like