Talk, no audio when talking

NC= 21.0.3

I am using Talk for the first time.

The texts seem to work so far.

We tried a couple of audio calls. I person called me, but while we can connect, there is no sound. I know that I needed to give android permission to use my microphone. My other tester left before I could ask if he gave permissions.

If he did do that, then what else might be causing the silence? Do I need specific ports open on my server?

I found references to something called HPB. When is this needed, meaning what number of participants for audio/video??

Thanks for any ideas.

You will receive notifications because you created this topic.

I have made some progress.

I was able to text, and make an audio and video call with one user and it works fine.

I tried with the original user, and it doe not work still not work. But, he tried sending me an image and it failed as well. But, it gave an error message when this happened. Hopefully this will mean something to someone in the forums.

Does the error give any clues as to the underlying cause?