Synology - reaching Nextcloud via does not work


I managed to install nextcloud on my Synology Disk Station and everything works fine when I try to connect to it from my LAN. (I followed this Howto: Nextcloud Installation auf einer Synology DiskStation mit DSM 7.0 | Viking Studios Blog)

When I try to connect to it from the browser via the Synology provides it cannot connect properly, I get (tried Firefox and Safari) the error “Access to untrusted domain”. Usind the mac-app also does not work.
I already added the address to my trusted domains in my config.php:

  array (
        0 => '***',
        1 => '192.168.***.***',

Also - and I find this espectally weird: from my mobile phone I can access the nextcloud! (via firefox mobile)

Does anybody have an idea what I am doing wrong?

Hi haukew,
just for the troubleshooting: remove the ip address from the array and try again.
From the screenshots I assume, You use the FQDN while connected to your local LAN, too.

At the moment I assume, that it somehow conflicts with the IP.
If it does not solve your issue, put it back in, to get a clean status back again.

Hi Carsten,

thank you for replying! :slight_smile:

I changed the array to:

array (
        0 => '***',

Unfortunately the error persists. Is there maybe a log-file that says explicitly, which domain I should add so I can avoid this problem?

Have a nice start into the week!

Maybe a problem with MacOS. Can you test with Windows or Linux.
Do you use e.g. a proxy for filtering web traffic?
Can you check if the TLS certificate is not broken from a virus scanner?

Hi devnull, thanks for the reply,

switching the OS is a good idea, I just tried accessing Nextcloud via browser on:

  • Manjaro Linux (up-to-date)
  • Windows 10 (also up-to-date)

both from my own private network and from a VPN. The results remain the same, the domain is not trusted. I do not use a proxy. (By the way: I can easily access the Nextcloud on my RaspberryPi from which I “upgraded” to the one on the Synology. For accessing the RPi from the internet I use DuckDNS as a DynDNS-Solution)

Regarding the virus scanner: I have none on my Synology, the Mac or the Manjaro Laptop.

Have a nice day!

Another thing I just tried: When I enter my Sylology´s external IP into the browser´s addressbar and put it into the config.php I still get the “Access to untrusted domain” error. Independent of operating system (tried it on Mac/Linux).
On the other hand when I remove the local IP from the config.php, accessing it via the local IP also results in a not-trusted-domain error. So at least the system works that way.

It seems the case that entering domains in the config.php does not work when accessing from outside my internal Network. Accessing my nextcloud from the outside seems to be “always not trusted”.