[Synology DSM6] File not found. The specified document has not been found on the server

Hi All,

I’ve been trying to get a nextcloud installation on my Synology.
I’m using Webstation in combination with Apache 2.4/PHP7.0.15/MariaDB. Here’s what I did so far:

  • I’ve uploaded all files
  • chown http:http -R nextcloud
  • Ran installation (Admin user fill in, database settings, data dir, etc)

When pressing INSTALL Nextcloud goes to work as expected. After it’s finished nextcloud comes back with the error:

**File not found. **
The specified document has not been found on the server
You can click here to return to Nextcloud.

Looking at the error log in /var/log/httpd I see this error:

2017-01-31T15:42:05+01:00 Bignasventi [Tue Jan 31 15:42:05.074327 2017] [proxy_fcgi:error] [pid 7541:tid 140553828112128] [client] AH01071: Got error 'PHP message: PHP Fatal error: Class 'OCA\\Files_Sharing\\AppInfo\\Application' not found in /volume1/web/nextcloud.domain.nl/apps/files_sharing/appinfo/app.php on line 36\n

And I see this in the nextcloud.log:
{"reqId":"1x3dCFzOIr4gQApkqGAX","remoteAddr":"","app":"PHP","message":"PHP Startup: No such handler: DBA_DEFAULT at Unknown#0","level":3,"time":"2017-01-31T14:55:24+00:00","method":"GET","url":"\/index.php\/apps\/files\/","user":"datadase_user","version":""}

I’ve tried setting permission full open. ( chmod 777 -R nextcloud.domain.nl ) > No effect
Tried setting permission through the Strong Permission Script. No effect.
I’ve followed tutorials found through google, but still I get the same error.

Has anyone encountered there errors before using Synology DSM6 Webstation?

Do you have all required php modules:

Yes, when running php56 -m I see all modules needed. The only one missing is the redis cache module. Did the same for php70 -m and this listed a whole lot less of loaded modules. So I changed to php56, but got the exact same error. But still this one is optional. Because webststation from synology is no normal webserver as you would expect. It has the possibility to choose apache version ( i chose apache 2.4) and PHP version (tried both 7.0 and 5.6). But still no go.
I also find this error message strange “PHP Startup: No such handler: DBA_DEFAULT at Unknown#0”. It’s like it is unable to find fin the default database handler. In my case mariadb.
I think I’m going to start over completely, uninstalling webstation, mariadb and both php versions. reinstall them and again follow some of the tutorials. If that does not work I’m looking into docker, as there is a nextcloud image of docker.

I’m experiencing the same problems, except I don’t see anything in the nextcloud log, but maybe i’m looking at the wrong location.

I also started a thread on the Synology forums, but no response so far.

Please keep us posted if you find a solution.

The redis module is not required. Can you also run php as module? Not sure how to install proxy_fcgi:error correctly. Did you check some threads with fcgi-configs? If not, perhaps try to ask on github.com/nextcloud/server/issues why you get a fatal error.

I experienced the same issue after another failed update using the updater app. I finally managed to complete a new install and use Nextcloud by downgrading to Apache 2.2.
I hope this helps.

This still did not work for me. I eventually bought a low powered thin client. Installed Centos and from there I installed Nextcloud. There is only one thing I need to take of now for which I opened a new thread.
But still thanks for helping.

1 Like